• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 912
  • Last Modified:

Exchange 2010 not receiving emails from external senders

Hello experts,

We have an Exchange 2010 behind a NAT, port 25 is forwarded to the exchange server.

Everything was running well. But today, I noticed that nobody is no longer receiving emails from outside the organisation.

When I send a test message from any other account (hotmail, gmail, another exchange organisation) I never get any rejection or delayed delivery notification. But in my mailbox, there are only messages coming for colleagues in the same organisation.

I used (Tracking Log Explorer) in EMC to see all messages today (about 100 nos), and found all of them are coming from senders in ourorganisation.com domain.

How to track and troubleshoot what is going on our email server?
0
Muhajreen
Asked:
Muhajreen
1 Solution
 
James HIT DirectorCommented:
Let's check a few things:

1. MX record: go to www.mxtoolbox.com
              Enter your domain name and verify MX records are visible
2. Port 25 test: telnet to your server from outside:

command: telnet <server name/IP> 25
See if you get a response.
0
 
Alan HardistyCommented:
Sounds like you may have discovered the Backpressure 'feature'.  Please have a read of my article:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_4259-Exchange-2007-2010-Backpressure-Quick-Fix.html

Alan
0
 
MuhajreenAuthor Commented:
Thanks for your quick response.


Telnet is working and responding well.

mxtoolbox.com:

      SMTP Reverse Banner Check      Reverse DNS FAILED! This is a problem..      Ignore
      SMTP TLS      OK - Supports TLS.      
      SMTP Connection Time      0 seconds - Good on Connection time      
      SMTP Open Relay      OK - Not an open relay.      
      SMTP Transaction Time      11.684 seconds - Not good! on Transaction Time      Ignore

EHLO please-read-policy.mxtoolbox.com
250-VExchange.ourdomain.com Hello [64.20.227.133]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250-XRDST
250 XSHADOW [265 ms]
MAIL FROM: <supertool@mxtoolbox.com>
452 4.3.1 Insufficient system resources [5288 ms]
RCPT TO: <test@example.com>
503 5.5.2 Need mail command [5320 ms]
QUIT
221 2.0.0 Service closing transmission channel [281 ms]
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Alan HardistyCommented:
"Insufficient system resources" = Backpressure.  Please use my article for a quick fix and then clear up some space on your disk(s), which is the usual culprit.

Alan
0
 
MuhajreenAuthor Commented:
GREAT GREAT

You drawn my attention for that low disk space. Let me fix the problem and get back to you.
0
 
MuhajreenAuthor Commented:
After making space, what shall I do? restart something or wait?
0
 
Alan HardistyCommented:
No need - it should notice and mail-flow should return.
0
 
SmightyCommented:
Since you've already found the source of your problem, there won't be a need for my input. But it does you no harm to check if your Recipient Connectors are set properly.

Your Connector should accept Anonymous Connections on the Network Card that faces the internet.
0
 
Simon Butler (Sembee)ConsultantCommented:
You can restart the MS Exchange Transport Service to force things along a bit. That will shorten the polling time by back pressure.

Simon.
0
 
MuhajreenAuthor Commented:
Thanks a ton. It's working now and many messages have just arrived.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now