Solved

Show IP BGP

Posted on 2013-01-10
5
320 Views
Last Modified: 2013-01-13
I would like to understand why show IP bgp displays those 2 lines.
I have configured 2 routers directly connected by a serial interface.

Router2#sh ip bgp
BGP table version is 4, local router ID is 10.10.10.20
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 10.10.10.10              0    100      0 i

Open in new window

Router1#sh ip bgp
BGP table version is 4, local router ID is 10.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i10.10.10.0/24    10.10.10.20              0    100      0 i
*>                  0.0.0.0                  0         32768 i

Open in new window



Router1#sh run
Building configuration...

Current configuration : 910 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.10.10.10 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0
 neighbor 10.10.10.20 remote-as 100
 no auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Open in new window




Router2#sh run
Building configuration...

Current configuration : 910 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.10.10.20 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0
 neighbor 10.10.10.10 remote-as 100
 no auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Open in new window

0
Comment
Question by:jskfan
  • 3
  • 2
5 Comments
 

Author Comment

by:jskfan
ID: 38765966
I need to understand the meaning of the 2 lines:

Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 10.10.10.10              0    100      0 i

   Network          Next Hop            Metric LocPrf Weight Path
* i10.10.10.0/24    10.10.10.20              0    100      0 i
*>                  0.0.0.0                  0         32768 i
0
 
LVL 5

Assisted Solution

by:Rakesh Madupu JNCIE-SP #02079 CCIE-SP#47613
Rakesh Madupu JNCIE-SP #02079 CCIE-SP#47613 earned 500 total points
ID: 38766355
The 0.0.0.0 indicates that the prefix was learnt from the local router

As you can see

interface Serial0/0
 ip address 10.10.10.10 255.255.255.0
 clock rate 2000000

is a connected interface for R1 , and hence its showing the same.

Now , If you take the same thougth and expand, you see you have advertised the route into BGP which will be updated to the other neighbor, and here the advertised network is the same interface which is also used for peering.

Hence when R1 receives and update about R2 10.10.10.20 network , with the following command on R2, net 10.10.10.0 mask 255.255.255.0 , it will know that it can reach 10.10.10.20 via its own serial interface and also a Bgp update and '>' is what used to determine the best path , what path would be more better than a direct path :)

Regards
Game
0
 

Author Comment

by:jskfan
ID: 38769885
why  next hop 0.0.0.0 is the best path.
I know you will say Local Preference (higher is better), but does it mean the router(that speaks BGP) knows that it is directly connected to other Router (that speaks BGP) then it kicks that Local Preference of 32768 ? if so, then does 32768 shows  in the table  only when 2 BGP routers are directly connected ??

thanks
0
 
LVL 5

Accepted Solution

by:
Rakesh Madupu JNCIE-SP #02079 CCIE-SP#47613 earned 500 total points
ID: 38769889
Next hop is 0.0.0.0 because , when you do a "show ip route connected" , the subnet should list under your directly connected interface which is more preferred than any protocol.
0
 

Author Closing Comment

by:jskfan
ID: 38773377
Thank you
0

Featured Post

Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Telepresence on backup 3 58
Juniper SRX 210H Throwing Error umass0: BBB reset failed, IOERROR 4 53
Routing between two networks? 10 90
Cisco Edge Routers for BGP 6 96
New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question