Linux Debian Cron Mount cifs issue

Posted on 2013-01-10
Last Modified: 2013-11-13
I created a root task through the gnome-schedule to run the script below. The issue is that I get error but can't see why it won't mount the cifs. I can run this script without issues from a root terminal. I entered the full path of the command like some people suggest. I am using the bash with the script name when I run it from gnome-schedule. I also created a new task that just mount the drive and it is failing.

Any help would be appreciated.

Here is the script
/bin/mount -t cifs //x.x.x.x/syslog -o  username=myusername,password=mypassword /mnt/nfs

/bin/mkdir -p /mnt/nfs/dns/`hostname`-`date +%m-%d-%y`/etc/bind
/bin/mkdir -p /mnt/nfs/dns/`hostname`-`date +%m-%d-%y`/var/lib/bind

/bin/cp -r /etc/bind/* /mnt/nfs/dns/`hostname`-`date +%m-%d-%y`/etc/bind
/bin/cp -r /var/lib/bind/* /mnt/nfs/dns/`hostname`-`date +%m-%d-%y`/var/lib/bind

/bin/umount /mnt/nfs
Question by:CanadaCouncil
  • 6
  • 3
LVL 40

Expert Comment

ID: 38764510
are you providing full path name for the script as well?

Author Comment

ID: 38764517
the gnome-schedule  task call "bash /etc/bind_backup", I did provide the full path.
LVL 40

Expert Comment

ID: 38764525
but bash it self without path name. Does it work with other scripts?

Author Comment

ID: 38764550
I also created a task with

/bin/mount -t cifs //x.x.x.x/syslog -o  username=myusername,password=mypassword /mnt/nfs

and I get the same result the help from the mount command...

I tried a task without the "bash" and I get the same problem

See picture

I do have /mnt/nfs and if I manual
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

LVL 40

Expert Comment

ID: 38764618
it looks like mount is not recognizing the file system type !

Author Comment

ID: 38764669
As it turns out the script run but without the mount so it copies everything but not on the network.

Author Comment

ID: 38764678
To reply to the comment... It does reconize it but not entirely. Are there logs anywhere?  The script works when it is being executed as root!

Accepted Solution

CanadaCouncil earned 0 total points
ID: 38768472
I found a work arround thanks anyway...  I mount the drive in the /etc/fstab

Author Closing Comment

ID: 38782007
it is working

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Entering a date in Microsoft Access can be tricky. A typo can cause month and day to be shuffled, entering the day only causes an error, as does entering, say, day 31 in June. This article shows how an inputmask supported by code can help the user a…
In this fourth video of the Xpdf series, we discuss and demonstrate the PDFinfo utility, which retrieves the contents of a PDF's Info Dictionary, as well as some other information, including the page count. We show how to isolate the page count in a…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now