Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cannot Log in to Citrix

Posted on 2013-01-10
5
Medium Priority
?
4,995 Views
Last Modified: 2013-01-14
I have a Citrix server running XenApp 6.5 on one farm, no gateway, etc.  Either after I installed one published app or re-started the server, users can no longer log in to the server.  Using my login, I receive the error:

Please verify your user name and password and try logging on again. If you cannot log on, contact your help desk.

After looking at the event log on the Citrix Server, I see three events tied to the failed login:


Informational Event ID 30401

Site path: C:\inetpub\wwwroot\Citrix\XenApp.

A socket has been forcibly destroyed by the transaction layer. [Unique Log ID: 6ca3841d]

For specific information about this message, see the Web Interface documentation at http://support.citrix.com/proddocs/topic/web-interface-impington/wi-log-messages-event-ids-hardwick.html.



Error Event ID 30024

Site path: C:\inetpub\wwwroot\Citrix\XenApp.

The XML document sent by the Citrix servers could not be processed because it contains invalid XML. This message was reported from the XML Service at address . The specified Citrix XML Service could not be contacted and has been temporarily removed from the list of active services. [Unique Log ID: 962b2088]

For specific information about this message, see the Web Interface documentation at http://support.citrix.com/proddocs/topic/web-interface-impington/wi-log-messages-event-ids-hardwick.html.



Error Event ID 31003

Site path: C:\inetpub\wwwroot\Citrix\XenApp.

All the Citrix XML Services configured for farm XXX Farm failed to respond to this XML Service transaction. [Unique Log ID: d6fdb4dc]

For specific information about this message, see the Web Interface documentation at http://support.citrix.com/proddocs/topic/web-interface-impington/wi-log-messages-event-ids-hardwick.html.



I searched through the Citrix forums and looking up the event ID's trying different suggestions.  I verified the XML port (8080) is the same in the web interface as in the AppCenter, tried unregistering and re-registering with a different port, etc.  


I cant find anything else to try.  I'm not a Citrix pro but I can stumble my way through it.  Does anyone have any troubleshooting or tips to try?
0
Comment
Question by:AllDaySentry
5 Comments
 
LVL 9

Expert Comment

by:Vijaya Reddy Pinnapa Reddy
ID: 38767504
Check the XML service status. If it is in stopped state. Start it.
If it is already in started state, unregister the XML service and register the service with r8080 instead of r80. Follow below article,

http://www.99technuts.com/virtualization/xenapp/troubleshooting-issues/service-failures/citrix-xml-service-fails-to-start/


Change port number to 8080
0
 

Author Comment

by:AllDaySentry
ID: 38768689
Thanks for the post but I have tried that a couple of times already.  Does not change anything.  The XML service is running.  I've also tried changing ports to 8081 instead of 8080.
0
 
LVL 23

Assisted Solution

by:Ayman Bakr
Ayman Bakr earned 375 total points
ID: 38771320
Can you try replacing the XML hostnames in the Web Interface configuration with their IP addresses?

If this resolves the issue, then there is a problem in your environment resolving the hostnames of the XML servers.
0
 
LVL 19

Accepted Solution

by:
basraj earned 375 total points
ID: 38772023
1. Request you to install all the recommened hotfix for the Xenapp available in Citrix site
2. Check XML port both on the web interface and also on the XenApp server. If same problem, change XML port at both the places.
0
 

Author Comment

by:AllDaySentry
ID: 38775038
I ended up rolling back the Citrix Server to the last good backup and it is up and running since I couldn't keep it down any longer.

Mutawadi,

Thanks for the suggestion.  I did not try that.  Not sure why it would be since I have everything running on one Citrix Server.


Basraj,

I did try downloading the hotfix rollup package from Citrix.  Seems to have made it worse since after I did that, I couldn't even get the web interface to load.

Tried changing the XML port in both locations from 8080 to 8081.  The port change seemed to work but still no luck.
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
Working from home is a dream for many people who aren’t happy about getting up early, going to the office, and spending long hours at work. There are lots of benefits of remote work for employees.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question