Solved

share internet using wifi, want to see wifi options

Posted on 2013-01-10
24
415 Views
Last Modified: 2013-02-03
I want to share clear internet 4g usb, I can not see options on wifi (such as setting up wifi password or wifi ssid)

sharing TO what device
similar to this question on another windows 7 computer
where I am given a choice of what device to share to (but given an error)
http://www.experts-exchange.com/Networking/Misc/Q_27988739.html

I hope this is a similar question (using two computers to complete the same networking task) and not a duplicate question, which I would delete.
0
Comment
Question by:rgb192
  • 12
  • 12
24 Comments
 
LVL 44

Expert Comment

by:Darr247
ID: 38765126
In Manage Wireless Networks from the Network & Sharing Center, click Add.
Click Create an ad hoc network read the notice and click Next
For 'Network name' make it, say, Share4G, use the default WPA2-Personal and enter an 8 to 63 character passphrase in the Security key field. Check the Save this network box and click Next.

The other clients will connect to the AdHoc network they see named Share4G, enter the passphrase, and then they should be able to reach the internet, assuming the 4G adapter is currently connected to the nearest tower. You can use whatever SSID/network name you want, of course... i.e. it doesn't need to be Share4G... but I wouldn't set it up permanently with no security.
0
 

Author Comment

by:rgb192
ID: 38765308
I created adhoc network Share4G

other computers can connect

but no internet
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38765452
Check the Internet Protocol Version 4 (TCP/IPv4) Properties for the Wireless Network Connection in the Change adapter settings section from the Network & Sharing Center.

That should show the wireless adapter to have been set to a static IP of 192.168.137.1.
Like so
Static IP for 'inside' adapter of ICS bridge
Selecting the box to share the 4G adapter's connection on its Sharing tab should make that change automatically to the Wireless Network Adapter (if it's the only 'inside' adapter as you showed in your original screen grab... otherwise, if there are multiple network adapters available you would need to choose which adapter to use from a picklist).
0
 

Author Comment

by:rgb192
ID: 38765550
>>
Check the Internet Protocol Version 4 (TCP/IPv4) Properties for the Wireless Network Connection in the Change adapter settings section from the Network & Sharing Center.

is this the clear internet device (incoming internet)

or the wifi (outgoing internet)

I tried with the clear internet device and had no change
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38765718
> is this the clear internet device (incoming internet)
No, the WiMAX adapter was named Local Area Connection 2 according to your first screen shot.
And technically, that's the 'outside' (or WAN) interface of the router/bridge that ICS creates.. the 'outside' interface is the one on which you want to enable Internet Connection Sharing on its Sharing tab.


> or the wifi (outgoing internet)
Yes, that's the one that was named Wireless Network Connection in the screen shot.
And that's the 'inside' (or LAN) interface that the ICS router's DHCP server will hand out addresses through in the 192.168.137.xxx /24 range.

Where it says Use the following DNS server addresses, you can use 8.8.8.8 if there's nothing in it (as shown in my example)... it *should* put the DNS address there picked up from the outside interface, but if it's empty, that (8.8.8.8) is a DNS server run by Google which should eliminate DNS problems from the fish/tree.
0
 

Author Comment

by:rgb192
ID: 38767429
I can create
but not modify the adhoc network

because I can not find after I create
(expect for wifi where I can connect to adhoc or other secure networks in my building)
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38767949
In Network and Sharing Center, click Manage wireless networks on the left.
It should be listed there... right-click on it and choose Properties

If it's not listed there, you missed the "Check the Save this network box " part of http:#a38765126 and you'll need to create it again... because if you don't check that box the ad hoc network is deleted every time you reboot.
0
 

Author Comment

by:rgb192
ID: 38768978
all my history of wireless networks appear in
control panel > manage wireless networks

(including me going to starbucks)

I see all the adhoc networks that I have created but I can only change password and connect automatically
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38769276
Yes... Security type (which really sets the "authentication" type) and encryption type (AES or TKIP) and the passphrase are about the only settings you can change in ad hoc networks on Win7... I don't believe you can tell Win7 and newer to connect automatically to any ad-hoc network using the Windows Wireless Zero Configuration service, though... that was an option in XP (but not the default since SP2 in XP) and vista, but it's too easy to use to phish passwords so it was eliminated altogether in Win7.

Which settings are you wanting to change besides those?
0
 

Author Comment

by:rgb192
ID: 38769486
Which settings are you wanting to change besides those?

I can not give another computer internet
if I can not set the wifi information
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38770014
You're not telling us what "wifi information" you want to set.
0
 

Author Comment

by:rgb192
ID: 38770119
or be able to share the wifi from computer1 that has clear internet device to computer2
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 44

Expert Comment

by:Darr247
ID: 38770166
That's not answering the question.

Computer2 (and 3 and 4, etc) should connect to the Ad Hoc network you created, and the Internet Connection Sharing on computer1 should do Network Address Translation (NAT) between the DHCP addresses it assigns and the Clear 4G adapter's connection.

So, what "wifi information" do you need to change?
0
 

Author Comment

by:rgb192
ID: 38771017
computers can connect to the ad hoc network, but do not get internet

I would like to get internet

what could be the error
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38771078
What IP addresses do the "computers" get when they connect to the ad hoc network?

Have you tried turning off their firewalls?
(not the ICS machine's firewall; the firewall[s] on the computer[s] connecting to the ad hoc network.)
0
 

Author Comment

by:rgb192
ID: 38771166
I tried turning off  firewall on windows 7 computer attempting to receive internet

this is a related question

http://www.experts-exchange.com/Security/Software_Firewalls/Q_27993589.html
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38771207
What IP addresses do the "computers" get when they connect to the ad hoc network?

The 'related question' linked above seems to about turning the firewall ON, not off.
0
 

Author Comment

by:rgb192
ID: 38772032
>>
What IP addresses do the "computers" get when they connect to the ad hoc network?


ipconfig in cmd.exe
which ip

how to see local ip address
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38773000
What operating systems are the other "computers" running?
0
 

Author Comment

by:rgb192
ID: 38776948
windows7
0
 
LVL 44

Expert Comment

by:Darr247
ID: 38776964
For win7 the wireless adapter is called "Wireless Network Connection" by default.

Usually, the fastest way to see its IP address is click the wireless icon in the tray, then right-click on the ad hoc network ("Share4G" was the example I gave in my original reply, but whichever network it's connected to, it should say Connected on the right) and choose Status.
Then either look on the Details tab or click the Details... button.
0
 

Author Comment

by:rgb192
ID: 38833391
192.168.2.1
0
 
LVL 44

Accepted Solution

by:
Darr247 earned 500 total points
ID: 38833730
The problem is on their computer, not yours.

Win7's Internet Connection Sharing hands out addresses in the 192.168.137.0 subnet, not the 192.168.2.0 subnet, so it appears whoever's computer that is, has set a static IP of 192.168.2.1 in the Properties of their Wireless Network Connection, then the Properties of Internet Protocol Version 4 (TCP/IPv4).
0
 

Author Closing Comment

by:rgb192
ID: 38849341
so I am sending, but the computer receiving has problems

thanks
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now