Solved

Copiers and Apps can't authenticate to smtp mail server

Posted on 2013-01-10
11
1,066 Views
Last Modified: 2013-05-24
We have an ISA 2006 front end and SBS 2008 with Exchange 2007 for our mail server. We also have several Sharp Copiers that scan to email. None of the copiers can authenticate to our smtp mail server whether I use our internal mail server or external. Consequently, we have another server with SAP B1 that also cannot connect to the smtp mail server to enable the Outlook Integration Add on.

I've tried our internal mail server address, our external mail server address, ports 25, 587, 465, and 443.

I can open a telnet client to the mail server from the SAP server, and can authenticate a user. There is no firewall on the SAP server.

I have started the firewall query in ISA and watched it while I attempt to connect one of these devices to the mail server and no connection attempt comes across the log. Is this something that SBS2008 is causing? Like setting up a relaying connector for the copiers?

I am baffled. Any help is appreciated.
0
Comment
Question by:riley71
  • 3
  • 2
  • 2
  • +2
11 Comments
 
LVL 14

Expert Comment

by:RickEpnet
ID: 38765867
You need to authorize that device by adding it's IP address to the Receive Connector. Exchange Management Console / Server Configuration / Hub Transport / Receive Connectors / Windows SBS Internet Receive Servername Then add the IP address of the device to the "Receive mail from remote servers that have these IP addresses"
0
 

Author Comment

by:riley71
ID: 38765938
Ok. I have two Receive connectors. One for internal mail and one for external mail. The internal mail had a range set for authorized remote servers for our entire network (192.168.100.0/192.168.100.255) and the external had a range of (0.0.0.0/255.255.255.255) already configured. I removed the ranges and added only the SAP server's IP, but nothing has changed. Still can't connect to smtp server.
0
 
LVL 14

Expert Comment

by:RickEpnet
ID: 38765977
I would not have removed anything I would have just added. You want to add the IP address of the device like the Copier to the Connector that is called this "Windows SBS Internet Receive Servername" Or it will be the one that under "Permission Group" have only "Anonymous users" checked.

I would not change anything on any connector except to add the IP address.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 38766224
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38766272
The first thing I would do is run the wizard in SBS to configure your email again, as this is SBS you should have three connectors in there. That means you either removed one or haven't used the wizards to setup the server.

In a default configuration, internal resources can send email to internal users without authentication. If that isn't happening then something is setup incorrectly. The internal traffic should not be going through your ISA server, internal resources should point directly at the SBS server.

If you need to send to external recipients I would then setup a specific connector for application relaying. This is the main article on that process from the Exchange team:
http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

Simon.
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 
LVL 11

Expert Comment

by:hecgomrec
ID: 38766819
Sorry riley71, but I think your problem is more of authenticating the actual message rather than the IP.

Most likely your SMTP settings prevent relaying or connecting to the connector if you are not authenticated, not the machine but the user.  You must set a user for services in your AD and set on each machine that username and password to authenticate it.

I have several SHARP machines doing this around the company and when they fail to authenticate most of the time is because the DNS I set them to work with is down.  Most likely this is not your scenario.

Try to look under your Network settings (Printer, Copiers) you should find a section to set your DNS and SMTP server and authentication.

Good Luck
0
 

Author Comment

by:riley71
ID: 38768741
Thank you for all of your responses:

Rick:
I have added the ranges back in and both ip addresses of the SAP server. It still didn't go. There actually are three receive connectors there. One with our server FQDN, and one with our external mail FQDN. There is also something called Windows SBS Fax Sharepoint.

It won't let me add the ip addresses to both receive connectors, so I tried it on both the internal and the external individually. I also unchecked all all permission groups on the internal connector except anonymous users. The exchange servers and windows authenticated groups were checked before. Still no joy.

Akhater:
I may be wrong, but the article seems to apply to remote servers in remote locations. Do these steps apply to devices within the network?

Sembree:
You are correct. The wizard was not used to set up Exchange. The SBS Server was installed to replace several 2003 Enterprise servers when I took over IT here. We have 23 users. It was total overkill. So Exchange 2003 was migrated to SBS 2008. I also did not run the internet connection wizard since the ISA server was left on the front end for internet monitoring and it's superior firewall. Will running the wizard now dismount the mail database? Or will all the mailboxes stay in tact? Will it affect our OWA features? I am nervous, but will run the wizard if it will correct these issues we are having.

hecgomrec:
Not sure I follow here.. There are AD user accounts set up for the copiers as well as SAP. I have even tried authenticating with admin credentials, but nothing doing. However, with the changes I made to the permission groups described above, I CAN connect the copiers leaving the credentials blank. However, SAP will not connect this way.

Where do I go from here?
DNS is set up in the copiers along with our gateway.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 38769592
these steps apply to any configuration doesn't matter if the devices are in or out of the netwrok
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 38769887
SBS is designed to be configured with the wizards. Trying to run SBS without using the wizards will give you inconsistent results. Many of the problems I see with SBS are caused by not running the wizards and setting up the server and network in the way that it wants.
I would encourage you to run the wizards to configure the server, and where possible use the wizards for setting up users, computers etc. You will need to take care as the SBS server will change things around and that could cause you some problems. It isn't anything major, but spend a weekend afternoon doing it and testing things and you should be fine.

Simon.
0
 
LVL 14

Expert Comment

by:RickEpnet
ID: 38770181
I agree always always always use the Wizards in SBS. Learn the hard way on that years ago. I thought I knew better found out I did not.
0
 
LVL 11

Expert Comment

by:hecgomrec
ID: 38774293
Can you tell me one of the Copiers Brand and Model so I can look up the options I mentioned above.
0

Featured Post

Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now