Solved

881G connection problem

Posted on 2013-01-11
7
1,094 Views
Last Modified: 2013-02-01
Hi,

I currently have a customer utilising a Cisco 881G router as a temp connectivity method (Cisco 1801 ADSL router is primary), with a 3G HWIC card. The connection works fine, the 1801 connects to the 881G router, via LAN, and builds a VPN through the 3G WAN, into our network.

Everything works fine for a while until the 3G connection drops (presuming through signal strength dropping) and then will not automatically re-connect. We have to power cycle the 881G in order for the 3G to re-establish.

I can't determine what the actual cause of the drops are, or what state the cellular interface is showing whilst it is 'down' as it is a remote site.

Just wondering if anybody has seen anything similar or the same?



I've included a copy of the 881G config, with bits removed for security:

version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mandb-3g
!
boot-start-marker
boot-end-marker
!
!
logging buffered 64000
enable secret 5 $1$P2D3$twamwP1EKPaqqRCrCMoA7/
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
memory-size iomem 10
clock timezone GMT 0 0
clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
crypto pki token default removal timeout 0
!
!
ip source-route
!
!
!
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
chat-script voda "" "ATDT*98*1#" TIMEOUT 10 "CONNECT"
license udi pid CISCO881G-K9 sn FCZ1550C2AU
!
!
archive
 log config
  hidekeys
username xxxxxxxxx password xxxxxx
username xxxxxx password xxxxxxxx
!
!
!
!
controller Cellular 0
!
!
!
!
!
!
!
!
interface FastEthernet0
 no keepalive
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Cellular0
 description Primary WAN Interface
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer string voda
 dialer-group 1
 async mode interactive
 no ppp lcp fast-start
 ppp chap hostname xxxxxxxxx
 ppp chap password xxxxxxxx
 ppp ipcp dns request
!
interface Vlan1
 ip address 192.168.0.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
logging esm config
access-list 1 permit 192.168.0.0
access-list 1 permit any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
no cdp run

!
!
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line 3
 exec-timeout 0 0
 script dialer voda
 modem InOut
 no exec
 rxspeed 7200000
 txspeed 5760000
line vty 0 4
 access-class 101 in
 transport input all
!
scheduler allocate 20000 1000
end
0
Comment
Question by:DScouser
  • 4
  • 3
7 Comments
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 38766572
your confgs looks fine.

can you please put

int c0
dialer idle-timeout 0

also can you post:

sh cellular 0 network
sh cellular 0 radio
sh cellular 0 all
0
 

Author Comment

by:DScouser
ID: 38766611
thanks for the response, I've added that line to the cellular 0 interface, so will monitor.


Output as requested:


xxxxxx-3g#sh cellular 0 network
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSPA (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = GBR, Network = O2 -UK
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 10
Location Area Code (LAC) = 43282
Routing Area Code (RAC) = 125
Cell ID = 34402
Primary Scrambling Code = 394
PLMN Selection = Automatic
Registered PLMN = O2 - UK , Abbreviated = O2 -UK
Service Provider =



xxxxx-3g#sh cellular 0 radio
Radio power mode = ON
Current Band = WCDMA 2100, Channel Number = 10661
Current RSSI = -83 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
        Primary Scrambling Code = 0x18A
        RSCP = -83 dBm, ECIO = -6 dBm



xxxxx-3g#sh cellular 0 all
Hardware Information
====================
Modem Firmware Version = K2_0_7_35AP C:/WS/F
Modem Firmware built = 03/04/10
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 234104303844475
International Mobile Equipment Identity (IMEI) = 353223046611837
Integrated Circuit Card ID (ICCID) = 8944110065440421726
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) =
Factory Serial Number (FSN) = C9E138206531007
Modem Status = Online
Current Modem Temperature = 31 deg C, State = Normal
PRI SKU ID = 9993559, SKU Rev. = 1.2

Profile Information
====================
Profile 1 = ACTIVE*
--------
PDP Type = IPv4
PDP address = 10.152.129.146
Access Point Name (APN) = mobile.o2.co.uk
Authentication = CHAP
Username: mobileweb, Password: password

 * - Default profile

Data Connection Information
===========================
Data Transmitted = 403681 bytes, Received = 74707 bytes
Profile 1, Packet Session Status = ACTIVE
        IP address = 10.152.129.146
        Negotiated QOS Parameters:
        Precedence = Normal Priority, Delay = Class 2
        Reliability = Unack GTP, LLC, Ack RLC, Protected data
        Peak = 256 kB/sec, Mean = 50000 kB/hr
        Traffic Class = Interactive
        Uplink Max = Unknown, Guaranteed = 16kbps
        Downlink Max = Unknown, Guaranteed = 64kbps
        Max SDU size = 1500 bytes
        SDU error ratio = 1E-4, BER = 1E-5
Profile 2, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
        Inactivity Reason = Normal inactivate state

Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSPA (Attached)
Packet Session Status = Active
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = GBR, Network = O2 -UK
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 10
Location Area Code (LAC) = 43282
Routing Area Code (RAC) = 125
Cell ID = 34402
Primary Scrambling Code = 394
PLMN Selection = Automatic
Registered PLMN = O2 - UK , Abbreviated = O2 -UK
Service Provider =
         
Radio Information
=================
Radio power mode = ON
Current Band = WCDMA 2100, Channel Number = 10661
Current RSSI = -83 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
        Primary Scrambling Code = 0x18A
        RSCP = -82 dBm, ECIO = -6 dBm


Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
0
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 38766707
3G status looks fine..

are you getting IP on the cellular interface?
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 

Author Comment

by:DScouser
ID: 38766751
yep, cellular 0 gets an IP address no problem... and all works fine, internet access, VPN over etc

The issue is, when the 3G signal drops, it never re-establishes automatically. The 881 has to be power cycled to bring connectivity back.... could this be down to ISP Lease times on there DHCP WAN IP addresses?

For extra info, the 881 is running ios 151-2.T4. I've tried searching for known bugs of this nature but to no avail.
0
 
LVL 9

Accepted Solution

by:
Sandeep Gupta earned 500 total points
ID: 38766778
Generally ISP don't give such less lease..

its an IOS issue..try using c880data-universalk9-mz.151-4.M3.bin

My all 881G routers are running on it and working fine.

cheers
0
 

Author Comment

by:DScouser
ID: 38767135
I'm in the process of uploading IOS c880data-universalk9-mz.151-4.M5.bin, fingers crossed this does the trick... I'll keep you posted!
0
 
LVL 9

Expert Comment

by:Sandeep Gupta
ID: 38768638
Sure...
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now