Disable Java on all workstations

Due to the warning posted by Homeland Security I have been directed to disable JAVA on all Browser and on all Workstations. I have been looking through the internet and there are plenty of suggestions on how to disable automatic updating but as for disabling JAVA I have not found. Now on JAVA 7 update 10 you can go into the JAVA control panel on a workstation and disable but as for doing this via GPO I have not found a way.
TimSr. System AdminAsked:
Who is Participating?
ThinkPaperConnect With a Mentor IT ConsultantCommented:
Just went through this. You can modify group policy to disable javascript in IE on your workstations:

Computer Configuration>Administrative Template>Windows Components>Internet Explorer>Internet Control Panel>Security Page

For both:
Internet Zone
Restricted Zone

"Allow Active Scripting" - Disable

This would disable Javascript on everythign except websites that you explicitly defined as Local intranet or Trusted sites (which I hope you would already assume is safe).

** Just note that doing this will result in a lot of your userbase complaining about websites not working. Also - this would only apply for Internet Explorer, so if you are using other browsers (such as Firefox and Chrome) you're kind of SOL as you would have to find another solution to block it on those browsers.

The only other option is to do a mass uninstall of java which you should easily be able to do (remotely) with your software deployment app (or something like PsExec). But then again, this may cause a great deal of interruption for your user base. Ask your leadership how they wish to proceed before you start doing this (to cover your butt) - as it will cause A LOT of uproar when users notice things not working, since alot of stuff is javascript dependant.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.