• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 345
  • Last Modified:

Task Manager Only shows 3 gig of ram

I have a HP Pavillion with 6 gig of RAM installed it is 64bit. When I check to see the performance all it show is the one Processor I have quadcore and only shows 3 gig of RAM, and I have 6 Gig. What could be the cause of this?
0
rangersal1
Asked:
rangersal1
  • 3
  • 2
  • 2
  • +4
1 Solution
 
50calCommented:
Can you check the boot options in ms config to see if it has been restricted?

1.

select start -> run (or hold the windows key and press r)

2.

type msconfig and press return

3.

select the boot tab

4.

select advanced options

5.

check the number of CPUs and maximum memory properties
0
 
SandeepSr System AdministratorCommented:
Check what settings you have in the BIOS.

It could be BIOS restricting such use of resources, as normally Quadcore should show multiple logical CPU in the Task Manager.

Check what details you see in the BIOS how much RAM and what is the CPU Type? Also see if any limitations set over there.
0
 
arnoldCommented:
What does computer properties reflect.
What graphics card/s do you have? See of hat memory might be allocated/referenced there.
With the CPU it depends on the view options you have.
0
Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

 
nobusCommented:
how is it seen in device manager?
if wrong, it could be an Updated OS that went wrong (eg not updated fully)
and then you need to reinstall in most cases
0
 
mcnuteCommented:
stick out and stick in the ram bars of your hardware when the pavillion is turned off. Sometimes it is just a missing contact.
0
 
cpmcomputersCommented:
Hardware may be 64 bit
But is the vista o/s?

Right click computer then select properties to check version
If it is 64 bit it will say so specifically
0
 
rangersal1Author Commented:
I did the msconfig and the options were greyed out. I then checked marked it and selected the proper settings. The OS is 64 bit. When I go back to check to ensure if setting have stayed the processors stayed at 4 but the maximum memory went to 2048. Again I have over 6 gig of Ram. This is at boot though.
0
 
nobusCommented:
how much Ram is showing in the bios?
maybe they are different sticks (6 Gb) and some not working
0
 
rangersal1Author Commented:
The task manager now shows all four processors and a total of 6140 Physical Memory. There seems to be some strange behavior still though. The system when idle is still using 2.6 gb of RAM and the CPU Usage spikes to above 30%. The disk usage keeps poping up. I dont know if this is another whole set of issues. The Memory and CPU number seems to be solved now though. Still cant set it to max at boot for RAM though.
0
 
SandeepSr System AdministratorCommented:
As I asked check what settings you have in BIOS as that could be the one controlling your resources if any tweaks set over there.
0
 
nobusCommented:
it does not use 2.6 Gb ram; it only reserves it, since you have 6 available
>>  Still cant set it to max at boot for RAM though.   <<  what do you mean ?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now