[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

BackupExec Not Purging Exchange 2007 Transaction Logs

Posted on 2013-01-12
16
Medium Priority
?
889 Views
Last Modified: 2013-01-14
Hi,

We're running Exchange 2007 SP3 with multiple storage groups ('A-C users', D-F users' etc) I've just noticed that the 'Y-Z Users' groups has 1000s, of transaction logs in it, roughly 667,000, compared to a few 100 in all of the other storage group folders.

We do daily & weekly backups using BackupExec 2010 R3, and the last backup of this storage group was today, so the logs should have been purged. I have the backup settings set to 'full database & logs (flush commit logs)' however it doesn't seem to be happening for this storage group! Is there an issue with Backup Exec? Is there a way to purge them manually?

Any suggestions appreciated

Ben
exchange-last-backup.jpg
exchange-transaction-logs.jpg
exchange-backup-settings.jpg
0
Comment
Question by:bjblackmore
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 2
  • +2
16 Comments
 
LVL 6

Expert Comment

by:arroryn
ID: 38770025
Do you have the Advanced File Option licensing enabled? If so, there's a box "Process Logical Volumes for backup..."

This needs to be unticked for everything to purge properly. If you don't have the licensing for AOFO and the box is greyed out and ticked, it won't be causing an issue (obviously).
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38770029
Look backup dont purge logs for many a reasons

1. If there is some missing or affected log
2. Was there some LCR or SCR for this DB not working or down ?
3. Is this the only DB in this SG ?

- Rancy
0
 

Author Comment

by:bjblackmore
ID: 38770033
We don't currently use AOFO although I think we're licensed, but we unticked the option last use due to another issue (if I remember correctly).

So, would you recommend enabling AOFO, but unticking 'Process Logical Volumes' or just leave it all disabled?

It only appears to be the one storage group having the issue, the other 12 appear OK, and only have 100-200 logs, dated today, compared to Y-Z Users which seems to date back nearly a year!

Is it possible these 600,000+ log files are just orphaned and can simply be deleted? I found an MS article on how to check with Exchange 5.5, 2000, & 2003, but not for 2007!
exchange-aofo.jpg
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:bjblackmore
ID: 38770036
This is the only database in the storage group.
It is in an LCR cluster, but there haven't been any issues with it going down. Only time it's gone down is for scheduled maintenance, and then we move to the passive node in a controlled manner!
0
 
LVL 6

Expert Comment

by:arroryn
ID: 38770038
I think it can be left "as is" - without the setting enabled, it wouldn't be affecting the backup set.

Does the cmd command "vssadmin list writers" shed any light on it (I can't recall whether that would address the individual storage groups)
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38770043
I would simply enable Circular Logging Restart IS after production hours Disable Circular Logging again and then restart IS and this should take care of backup purge logs for that DB

- Rancy
0
 

Author Comment

by:bjblackmore
ID: 38770047
vssadmin list writers reports all OK.

@Rancy: I will try your suggestion this evening, and report back.
0
 
LVL 25

Expert Comment

by:Tony Giangreco
ID: 38770056
Yes, check the VSS writers. They should all be working properly and porting no errors.

Also, make sure Backup Exec is fully updated. run Live Update and apply all updates.

What version of BE are you running?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38770164
I am a bit off why are we checking with VSSWriters or others as only one is affected whereas all rest is working fine :(

- Rancy
0
 

Author Comment

by:bjblackmore
ID: 38770771
OK, this eveing I've enabled Circular Logging, restarted the Information Store, then disabled Circular Logging and restared the Information Store again. However there are still 667,000+ e***.log files in the folder.

I'm thinking that this have to be orphaned files surely!?

BE version as said is BE 2010 R3! With 6 hotfixes applied!
0
 
LVL 8

Expert Comment

by:Sumit Gupta
ID: 38770938
1. Disable LCR and Re-enable LCR.
 
2. Run a full backup again to confirm if it deletes the old logs and replays logs to the database ( event id: 916).
 
3. Output of Get-Storagegroupcopystatus command: The CopyQueueLength and ReplayQueueLength will now show 0 and the number of log files as 50. ( Note: The number 50 is hardcoded.)

References:
http://www.symantec.com/business/support/index?page=content&id=TECH126445
http://www.symantec.com/connect/forums/exchange-2007-log-files-not-purged
http://www.symantec.com/connect/forums/exchange-transaction-logs-not-deleting-after-full-backup
0
 

Author Comment

by:bjblackmore
ID: 38770953
Results of Get-Storagegroupcopystatus from earlier today:


Name                      SummaryCopyStatus       CopyQueueLength         ReplayQueueLength      LastInspectedLogTime  
----                      -----------------       ---------------         -----------------      --------------------  
A-B-C Users Storage Group Healthy                 0                       0                      12/01/2013 14:36:03  
D-E-F Users Storage Group Healthy                 0                       0                      12/01/2013 14:35:53  
G-H-I Users Storage Group Healthy                 0                       0                      12/01/2013 14:36:03  
J-K-L Users Storage Group Healthy                 0                       0                      12/01/2013 14:34:53  
M-N-O Users Storage Group Healthy                 0                       0                      12/01/2013 14:36:03  
P-Q-R Users Storage Group Healthy                 0                       0                      12/01/2013 14:35:53  
S-T-U Users Storage Group Healthy                 0                       0                      12/01/2013 14:35:53  
V-W-X Users Storage Group Healthy                 0                       0                      12/01/2013 14:36:13  
Y-Z Users Storage Group   Healthy                 0                       0                      12/01/2013 14:35:53  
VIP A-M Users Storage ... Healthy                 0                       0                      12/01/2013 14:35:03  
VIP N-Z Users Storage ... Healthy                 0                       0                      12/01/2013 14:35:33  
Archived Users Storage... Healthy                 0                       0                      12/01/2013 13:07:03  
Public Folders Storage... Healthy                 0                       0                      12/01/2013 14:35:03  

Currently running a full backup, but it can take a few hours!
0
 
LVL 52

Assisted Solution

by:Manpreet SIngh Khatra
Manpreet SIngh Khatra earned 1500 total points
ID: 38771804
So if Circular Logging didnt help these files dont seem to be a part of the live DB
Are you having LCR for all DB's ?

- Rancy
0
 

Author Comment

by:bjblackmore
ID: 38772157
Yes, all DBs setup in the same way. Only this one has the issue.

Creating a new backup job just for this storage group, and setting it to purge the log files didn't help.

I've also tried following the steps in the below URL, but that didn't help:
http://ilantz.com/2011/10/26/how-to-manually-purge-exchange-server-logs-clean-and-easy/

As you say, these don't appear to be part of the live DB, and must be orphaned files. I'm thinking that deleting every file older than a month is the only way to go! Just hope it doesn't have any detrimental effect!
0
 
LVL 52

Accepted Solution

by:
Manpreet SIngh Khatra earned 1500 total points
ID: 38772298
I would say one more suggestion

Dismount the DB
Stop Information Store service
Move all logs for this DB to another location (.log .jrs .tmp .chk) anything apart from .edb

Start Information Store service, DB's should mount and now check with Backup

- Rancy
0
 

Author Closing Comment

by:bjblackmore
ID: 38773728
Performed the steps suggested to clear out the orphaned E*.log files. Exchange has recreated a new set of E*.logs, whicch currents counts as 365, rather than the previous 667,000+. Hopefully this will resolve the issue, and they won't grow to that volume again!
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question