• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 496
  • Last Modified:

Sharepoint 2010 library permissions

I have 3 SP Groups that have Contribute permissions at the site level. I have a library that these groups can access, but I want only one individual in one of the groups to have contribute permissions on the library. I Stopped Inheriting Permissions on the library, but the group Contribute permissions are still allowing others to edit documents. I'm sure I must be missing something, but if a group has certain permissions at the site level how can they be changed in the context of a particular library or list?
0
dgmoore1
Asked:
dgmoore1
  • 6
  • 3
1 Solution
 
Levi GwynCommented:
It sounds like you did everything right so my answer is a guess.  On the library that you only want one person to have contribute rights to, go to library settings and remove all permissions for all groups (if you're not the site admin, give yourself full control first and obviously don't remove your permissions).

Add the groups back manually and manually give them read permissions.  Add the user back manually and give him/her contribute rights.
0
 
dgmoore1Author Commented:
I'll give that a try - will get back to you. Thanks
0
 
dgmoore1Author Commented:
OK - I created a new library as a test and assigned read access in the library permissions to one of my groups. But when logged in as a member of that group (using a test account) I can still add and edit docs. I remain puzzled.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Hello,

you can check where these permission come from by going Library Settings > Library permissions > check permissions. Then enter the name of the usere. Now you will see their permissions and also which group membership is granting them.

Check that the permission for "Read" has not been changed from the default. Permission levels can be freely defined. They are just labels. What counts are the actual permissions assigned to each permission level.

cheers, teylyn
0
 
dgmoore1Author Commented:
I did that and found that Contribute permission is passed to my test user account from the SP Group the user is assigned to. So I'm not seeing how to set permissions from the library level if they're overridden by permissions assigned at the site level. There must be something I'm not getting here.
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Within the library, you need to stop inheriting permissions, then select the tick box for the group and click Edit User Permissions on the ribbon. Select the Read permission level.

Now all members in that group will have the access defined in the "Read" permission level.
0
 
dgmoore1Author Commented:
That's what I did. But the members still have the Contribute permissions assigned originally to the group. Hence my puzzlement...
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
Can you post a screenshot of the changed permission settings for the group?
0
 
dgmoore1Author Commented:
Sure - I'll put it up tomorrow
0
 
dgmoore1Author Commented:
By removing the groups' permissions and adding them back I was finally able to get it working correctly. Thanks for you help.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now