Solved

Polycom HDX8000 not sending video and audio

Posted on 2013-01-13
32
1,453 Views
Last Modified: 2013-02-06
Hello,

I have connected my Polycom HDX8000 to the cisco 857 router.  I assigned public IP to the hdx device so there's no NAT relations. However, after dialing call the connection is established but far site cannot see or hear me.

 Please can someone help me to solve this issue.

 Appreciating the help.

 Thanks
0
Comment
Question by:cciedreamer
  • 12
  • 11
  • 6
  • +1
32 Comments
 
LVL 32

Expert Comment

by:nappy_d
ID: 38773160
Can you see and hear the far side?

If so, what is the resolution at which you are sending video?

Also, what is the upstream and downstream speed of your internet connection?
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38773329
Yes I can hear the far side.

I am not sure about the resotion as I am new this device

I have ADSL internet connection with download 4MB and  upload 0.25MB I have tried with other line where the download is 6MB and 3MB upload.

Thanks
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38775021
What kind of firewall is the far side using?
Do you allow all outgoing traffic from your side?
I assume you don't run the traffic in a VPN, is that right?

Tamas
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38775729
If you are not running NAT, then it should "just work" it might be useful for you to post the Cisco config.

Have you tried connecting to the Polycom test addresses ?
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 38776832
Here is what I suggest you do:

Make sure the HDX 8000 and monitor(s) are powered on
• Press the Call button on the remote to place a call
• A dialing window will open on your monitor along the top of the home screen
• Use the numbers and arrows on the remote control to navigate the call screen
• Use the keypad to dial the IP or ISDN number of the site you are calling. When dialing an IP
address, use the dot button on the remote control.
• Arrow to the “Quality” window to select call speed. Use the center button as an “Enter” button
• You can specify that you are dialing IP or ISDN, or let the system auto detect the call type
• Press the Call button to dial the call
• Make sure your microphone is not muted

Also, you may want to adjust the QOS on your firewall to make sure that your video calls get priority when it is in use.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38778021
@nappy_d that would appear to have been copied from http://virtualservices.kansasworks.com/Documents/Guide%20HDX%208000%20Series.pdf

I usually attribute where external information came from...
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38778024
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38778094
Hi Experts,
In my case, I have provided a realpresence software to the far side user. He is connecting to polycom device by dialing the public IP of  device. After answering the call from my side, the far side cannot see and hear me.

Far side does not have any kind of firewall He just have normal ADSL connection.

Thanks for the help.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38778493
Most ADSL connections have a single IP address and a NAT router.

Is the far side behind NAT ?
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38778535
Yes.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38778594
That is the problem.

H323 includes the host address in its packets.

To work behind NAT, you need to use PAT to forwardthe used ports to the computer running the H323 client, AND the router needs to be H323 aware so that as well as the port forward, it can rewrite the H323 packets.

For clarification, even a "DMZ mode" where all ports are forwarded to the computer will not work without the rewrite of the packets.

Alternatives are  

1/ Purchase (V expensive) a NAT traversal device at your side, this then rewrites the packets at your end.

2/ Replace the remote router with an ADSL router that is  H323 aware.

3/ Run the ADSL router in Bridge mode with a H323 aware firewall such as a Cisco ASA running at least version 8 behind the router.

4/ Run the ADSL router in bridge mode providing the client computer with the public IP address
 
Options 2/ and 3/  still require the port forward for calls To: the remote site, the client computer will need to be on a static internal address. Option 4 means that you should run  firewall on the client computer, and the line will be dedicated to it.

If the calls are all From: the remote site, you should not need the port forward, but the packet rewrite still needs to happen.
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 38781196
It sure looks like it however, that is not where I got the info and I always reference my info.  Someone have previously sent me this excerp some time ago in an email I have when I had a client with HDX issues..
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38781292
Perhaps that is where they got it from...
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794354
Hi,
Basically I'll be using my polycom to conduct video conference with the clients where everyone is not capable of having ADSL.

I am really disappointed with Polycom Device. I am just looking for basic thing. I have purchased these device more than 2 months and still I am not able use it. Really I am looking for a big help from EE experts to solve my weird problem.

Thanks
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38794472
Could you post a sanitized config from cisco and polycom?
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794515
Below is my router config.
Please let me know what are snapshots you need from Polycom so I can post that.

I have assigned 1.1.1.2 to polcyom device and router as a gateway.

sh running-config
Building configuration...

Current configuration : 4113 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash c850-advsecurityk9-mz.124-15.T14.bin
boot system flash c850-advsecurityk9-mz.124-15.T15.bin
boot-end-marker
!
logging buffered 4096
no logging console
enable secret 5 111111111111111111111
!
no aaa new-model
!

dot11 syslog
no ip dhcp use vrf connected
no ip dhcp conflict logging

ip cef

!
!
username admin privilege 15 password 7 111111111111
!

!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 1.1.1.1 255.255.255.248
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 ppp chap password 7 XXXXXx
 ppp pap sent-username XXXXXXXXXXXXXXXXXXXXXXXXX password 7 XXXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 100 interface Dialer1 overload
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password 7 111111111111111111
 login local
!
scheduler max-task-time 5000
end
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 17

Expert Comment

by:TimotiSt
ID: 38794536
The 1.1.1.2 address is a sanitized 192.168.x.x (or any other RFC1918/private) address?
The polycom can save config as an .xml file, could you post that? Remove passwords if there's any in it.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38794576
As per my previous your issue is NAT at the remote end.

Video works well when both addresses are public (or private on an internal network or over a VPN tunnel.

if the remote end is behind NAT and the router is not H323 aware, it will not work without a NAT traversal "server"  (such as the Polycom RealPresence Access Director) at the main site.

It is usually more cost effective to replace the remote routers/firewalls with devices that are H323 aware, than it is to purchase a NAT traversal "server", however if you need connectivity for remote clients from "anywhere" it may be your only option.

You could as an alternative, have the main site behind a H323 aware router/firewall and have mobile clients that are not behind a H323 aware router/firewall connect via VPN to the main site, at which point they can connet to the private address and not go over NAT.

I'm unsure what youmnean by "where everyone is not capable of having ADSL.". You can  use either  IP, or ISDN (provided you have the ISDN card and ISDN connectivity), neither is ADSL.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38794596
From your posted config,

You are using NAT at the main site,
The HDX does not have a public IP
You do not have NAT or PAT for inbound access to the HDX
You do not have H323 inspection enabled

This configuration will not work

Your original post said "I assigned public IP to the hdx device so there's no NAT relations"

Have you changed the config since then ?
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794603
Well in that case it's useless have a polycom device. I will be using this polycom devices in many way such as to conduct interviews with the candidates for our company, business clients. I am sure most of them will not have public address on computers or having devices capable of NAT traversal...

I do know what to do now.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794627
@ArneLovius
In my router configuration I have posted fictitious public IP's i.e 1.1.1.1 ( Router) and 1.1.1.2
HDX.
I have no NAT relations.
Yes. h323 insepection is not enabled on the router.
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38794631
Our HDX8000 works perfect behind a non-H.323 aware firewall, you just need to do some port-forwards on the firewall, and config the HDX with the public IP under the NAT config (not to be confused with its actual private IP). It's very flexible.
For far end we use the Polycom m100 on laptops, and it usually works just fine. Worst case we also need to let the m100 know the public external IP.

Tamas
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794677
@TimotiSt
I have also tried to configure polycom hdx 8000 behind ASA firewall. I also did port forwarding with recommended configuration Then also I was facing the same problem.
Then I decided to connect directly to the router by assigning public IP's even though same problem i.e polycom not sending video/audio.

Thanks.
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38794745
What software version is the HDX running?
I read the release notes for the latest (Dec/2012) software earlier today and it did mention some video send errors in some rare cases. Although I don't really think that's the problem in this case.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38794763
Software Version: Release - 3.0.5-22695

Samir
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38794889
You have NAT inside on the VLAN interface
You have NAT outside in the dialler
You have a NAt overload line ip nat inside source list 100 interface Dialer1 overload

You are running NAT...

I would suggest removing the NAT statements from the two interfaces.

@TimotiSt between two endpoints, or were you using a bridge with a public address ?
0
 
LVL 17

Expert Comment

by:TimotiSt
ID: 38794967
On the NAT note, I can't find access-list 100 for the actual NAT command in the config...
Yes, between endpoints. No bridge/proxy/anything. It even managed to work when I messed up the NAT and it became asymmetric on the HDX side.
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38795016
Polycom to Polycom might be possible, but I would suggest that you tried with a 3rd party client...
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38802598
I have unused removed NAT configuration from the router but still have same problem.

I will most welcome further suggestions.

Thanks
0
 
LVL 36

Expert Comment

by:ArneLovius
ID: 38802742
can you post a suitably sanitised copy of the current config
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38802779
Here it is

hostname Router
!
boot-start-marker
boot system flash c850-advsecurityk9-mz.124-15.T14.bin
boot system flash c850-advsecurityk9-mz.124-15.T15.bin
boot-end-marker
!
logging buffered 4096
no logging console

!

!

!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 1.1.1.1 255.255.255.248
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 ppp chap password 7 XXXXXXXXXXXXXXx
 ppp pap sent-username XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXx password 7 XXXXXXXXXXXXXXXX
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http secure-server
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password 7 123
 login local
!
scheduler max-task-time 5000
end
0
 
LVL 36

Accepted Solution

by:
ArneLovius earned 500 total points
ID: 38803109
You config indicates that you have a dynamic PPPoE connection over ADSL, and then  a static block /29.

First test, can you put a PC in the same subnet and test connectivity to the HDX using your soft client, you should be able to establish a connection on both directions.

Second test is to connect to the Polycom test IP addresses

http://support.polycom.com/PolycomService/support/latinamerica/support/documentation/video_test_numbers.html

Granted this is only a calling out test, but it establishes that a connection can be established.

Do let me know how you get on
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now