Solved

Exchange 2010 Outbound Mail keeps going via Exchange 2003

Posted on 2013-01-13
12
433 Views
Last Modified: 2013-01-18
I am migrating from Exchange 2003 and Exchange 2010.  All mailboxes have been moved out and can send/receive emails.

For some reason, I cannot set the Exchange 2010 to send mail outbound by itself.

As soon as I delete the routing group between 2003 to 2010, mail does not flow outbound (Inbound to 2010 is fine). When I add the routing group back, mail goes out. This suggests that mail is still going out via the 2003 Mail Server.

I have correctly created a Hub Transport Send Connector with * Address space and cost 1, setting as Internet and using our normal smarthost, but still no luck.

Somewhere I am missing the obvious but cannot work it out, please help?

Quick Background on this.
Exchange 2010 setup with all roles one one server. CAS setup correctly pointing to a CASARRAY DNS address.
DAG setup with DR Exchange 2010
All up to date ServicePacks applied

Thanks
0
Comment
Question by:cybernaz67
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
12 Comments
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38772076
Is there some firewall  if so does it has some rule to accept email from XYZ server on port 25 ?

- Rancy
0
 

Author Comment

by:cybernaz67
ID: 38772104
Hi,

Previous Exchange was setup by another guy and when I checked the firewall, outbound is fully open.

Inbound I have used another public IP for 2010, but inbound email to Exchange 2010 is fine.
The mail is routed via a smarthost from Messagelabs
0
 
LVL 19

Expert Comment

by:R--R
ID: 38772123
check if the source server is your hub transport server in send connector.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:cybernaz67
ID: 38772128
Yep, send connector is created, however I think I might now where the issues lies. I have not added the public facing IP address of the Exchange 2010 Server into the Messaglabs console which is out smarthost provider. Takes 1 hour to update, so will know if that is correct or not

thanks
0
 
LVL 19

Expert Comment

by:R--R
ID: 38772132
Did you opened the port 25 for Exchange 2010 on firewall.
You can enable SMTP log to further trouble shoot the issue.
0
 

Author Comment

by:cybernaz67
ID: 38772149
IP address is already in Smarthost website.  
Outbound on the firewall in all open., but good idea on checking the logs
0
 
LVL 19

Expert Comment

by:R--R
ID: 38772154
you can alos try to remove the routing group connector and send connector and recreate the send connector.
0
 

Author Comment

by:cybernaz67
ID: 38772194
just tried that deleted RGC and Send Connector, created new send, still now luck
0
 

Author Comment

by:cybernaz67
ID: 38772252
ok, guys, I must have had a Brain drain. The issue was the other way around. I could receive email to 2010, but not send from 2010 unless RSG was connected.
The fix was to go into my Smarthost portal and change the inbound route to point to the public IP of the Exchange 2010 Server, was set to 2003.. DOH ! will take approx 2hrs to update
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38772305
Wow so its the gateway issue ...

- Rancy
0
 

Accepted Solution

by:
cybernaz67 earned 0 total points
ID: 38773565
All fixed.
Just to clarify, in my Smart Host Portal, we have sections for both Inbound and Outbound Routes. All I had to do was to change the default route from the Public IP of my Exchange 2003 Server to now be the Public IP of my Exchange 2010 Server.
Thank You all for you input in this
0
 

Author Closing Comment

by:cybernaz67
ID: 38792347
Works
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question