Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Issue with Mac mail and external outlook users not connecting to exchange

Posted on 2013-01-13
8
Medium Priority
?
542 Views
Last Modified: 2013-01-28
Hi All,

We currently have an issue with exchange in both our internal/ external Mac users cannot connect to exchange and only external MS outlook users cannot connect.

All smart phone devices (i.e. iPhone, Android etc..) which are outside our domain network i.e. using a Mobile data connection can still connect and send and receive mail and all internal outlook users can connect + send/receive mail fine as well.

I have checked all obvious things such as the MS Exchange services and ensured they are all running, rebooted the Exchange server and also checked bindings within IIS and from what I can tell they appear to be OK.

I am now stuck on this and I can't see how it would be a network issue as mentioned above the smart phones (which are outside the network) are connecting and puling down the mail just fine. I am thinking its perhaps related to an active syc issue, but im am by far no exchange expert and urgently need the help and advise of a EE exchange guru to assit with this.

Thanks in advance,
A
0
Comment
Question by:Adma1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
8 Comments
 

Author Comment

by:Adma1
ID: 38773011
I should also add the OWA is working fine and can be accessed outside the network.
0
 

Author Comment

by:Adma1
ID: 38773072
I have performed auto discovery test using https://www.testexchangeconnectivity.com

See results below.

      Attempting the Autodiscover and Exchange ActiveSync test (if requested).
       Testing of Autodiscover for Exchange ActiveSync failed.
       
      Test Steps
       
      Attempting each method of contacting the Autodiscover service.
       The Autodiscover service couldn't be contacted successfully by any method.
       
      Test Steps note company name has been substituted with the word "company"
       
      Attempting to test potential Autodiscover URL https://company.com.au/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to test potential Autodiscover URL https://autodiscover.company.com.au/AutoDiscover/AutoDiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Test Steps
      Attempting to contact the Autodiscover service using the HTTP redirect method.
       The attempt to contact Autodiscover using the HTTP Redirect method failed.
       
      Test Steps
       
      Attempting to resolve the host name autodiscover.company.com.au in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 80 on host autodiscover.company.com.au to ensure it's listening and open.
       The port was opened successfully.
      ExRCA is checking the host autodiscover.company.com.au for an HTTP redirect to the Autodiscover service.
       ExRCA failed to get an HTTP redirect response for Autodiscover.
       
      Additional Details
      Attempting to contact the Autodiscover service using the DNS SRV redirect method.
       ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
       
      Test Steps
       
      Attempting to locate SRV record _autodiscover._tcp.company.com.au in DNS.
       The Autodiscover SRV record wasn't found in DNS.
0
 

Author Comment

by:Adma1
ID: 38773078
I also came ascross a forum suggestion to check the following:

On Exchange CAS server, open IIS console,
Go to default web site, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
Click Autodiscover, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
Click EWS, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
Click OAB, double click “SSL Settings”,  make sure Client Certificates is set to “Ignore”
Please run IISRESET command to load the changes.


i have checked each of these and can confirm our configuration is identical to the suggestion above.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 19

Expert Comment

by:suriyaehnop
ID: 38773603
If you are using Exchange 2007 and above and the mac user using entourage or Outlook for mac, please make sure you run update for both mac client. I had experianced for mac user unable to connect to exchange server when we did upgrade our Exchange 2007 few years back. After did some googling, we did update the mac client then mac user able to send/receive mail (internal/external)

It appeared to me that you have issue with SRV record:

Attempting to locate SRV record _autodiscover._tcp.company.com.au in DNS.
       The Autodiscover SRV record wasn't found in DNS.

Look at this link: http://support.microsoft.com/kb/940881, do it on your public DNS


Then run the test again.
0
 

Author Comment

by:Adma1
ID: 38773900
Hi thanks for the response,

The issue affects all Mac users and we only use the.native Mac mail client within snow leopard and our external users using outlook.

Its strange how this issue jut came about and nothing had changed in order to trigger the issue to occur.
0
 

Author Comment

by:Adma1
ID: 38773904
Also I read on forum I came across that the issue could be related to the exchange server not being able to identify the name on the certificate, but this has not changed and the certificate has not expired.
0
 

Accepted Solution

by:
Adma1 earned 0 total points
ID: 38812641
Hi all,

After a pain staking attempt to resolve this I found that the issue was in fact related to a .Net update, applying the following update resolved this issue.

http://www.microsoft.com/en-us/download/details.aspx?id=28949

Thanks for all the assistance with this issue to date.
0
 

Author Closing Comment

by:Adma1
ID: 38826205
Hot fix update resolved the issue and exchange now connects as required.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question