Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

Signing jar issue

Posted on 2013-01-14
Last Modified: 2013-01-15
Hello there,

I have around 40 jars which i have jarred and singed for my JNLP app. but when i run the jnlp app. i get following error.this is very weird becasue i have signed it,i also verified the jar by using this command

C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\kaizen>jarsigner -verify hibernate3.jar
jar verified.

This jar contains entries whose signer certificate will expire within six months.

Re-run with the -verbose and -certs options for more details.

#### Java Web Start Error:
#### Found unsigned entry in resource: http://localhost:8080/kaizen/hibernate3.jar
Trace level set to 5: all ... completed.
Question by:zolf
  • 4
  • 3
  • 2
LVL 86

Expert Comment

ID: 38774034
Does that have nested jars?
LVL 16

Expert Comment

ID: 38774120
check this, because I think this is your case, there is a solution proposed:
LVL 16

Expert Comment

ID: 38774250
may be this will be more helpful : https://hibernate.onjira.com/browse/HHH-5681
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.


Author Comment

ID: 38777007

How can i find it. I tried unjarring it and there was no jar files in it.but it had a pom file

Author Comment

ID: 38777020
by: Valeri

i did not understand this comment from that link. do i just need to delete the pom file from the hibernate.jar and again jar the hibernate3 folder.

Gail Badner added a comment - 21/Jan/11 1:06 PM

Fixed in git hibernate-core 3.6.

Author Comment

ID: 38777032
ok, i did as was told in that link and managed to get pass that unsign jar thingy. but now when i run the app. i get this error.

java.lang.NoClassDefFoundError: org/hibernate/HibernateException
      at com.MainFormX.<init>(MainFormX.java:234)
      at com.MainFormX$2.run(MainFormX.java:450)
      at java.awt.event.InvocationEvent.dispatch(Unknown Source)
      at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
      at java.awt.EventQueue.access$000(Unknown Source)
      at java.awt.EventQueue$1.run(Unknown Source)
      at java.awt.EventQueue$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
      at java.awt.EventQueue.dispatchEvent(Unknown Source)
      at custom.java.swing.event.DefaultTextPopupEventQueue.dispatchEvent(DefaultTextPopupEventQueue.java:30)
      at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.hibernate.HibernateException
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 17 more
LVL 16

Accepted Solution

Valeri earned 500 total points
ID: 38777203
what did you do? can you check if the missing file is presented in you jar file? As I can see from the link if you download version 3.6 or later, there will be no problem and you don't have to do anything else except to sign the jar.

Author Closing Comment

ID: 38777416
LVL 86

Expert Comment

ID: 38778014
So it's actually THIS that should have been marked as the correct answer ..?

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
servlet doXXX methods 3 61
How do I remove an object from a 3 40
sql import cannot be resolved jsp 3 44
Java Restore security prompts not working 10 50
Java contains several comparison operators (e.g., <, <=, >, >=, ==, !=) that allow you to compare primitive values. However, these operators cannot be used to compare the contents of objects. Interface Comparable is used to allow objects of a cl…
By the end of 1980s, object oriented programming using languages like C++, Simula69 and ObjectPascal gained momentum. It looked like programmers finally found the perfect language. C++ successfully combined the object oriented principles of Simula w…
Viewers learn about the scanner class in this video and are introduced to receiving user input for their programs. Additionally, objects, conditional statements, and loops are used to help reinforce the concepts. Introduce Scanner class: Importing…
Viewers will learn about basic arrays, how to declare them, and how to use them. Introduction and definition: Declare an array and cover the syntax of declaring them: Initialize every index in the created array: Example/Features of a basic arr…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question