Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1863
  • Last Modified:

WIndows 7 de-activates and fails to re-activate.

I work for a school system and we have random machines that are activated through KMS and then suddenly lose it.

When the machine comes up, it says it needs to activate and gives error code 0xc004f056

Other machines in the same classroom continue to function properly and I can ping the kms server from the affected machines.

Any ideas?
0
Joel Parmer
Asked:
Joel Parmer
  • 2
1 Solution
 
pr0t0c0l12Commented:
try testing KMS communication, it occurs on port 1688. use "telnet serverip.domain.com" and the port 1688
example:
telnet serverip.domain.com 1688
if it opens, then you have communication to it.  next you need to make sure that you have access to the service record on your DNS (example:  

Service: _VLMCS (This is not in the drop-down list and must be typed.)
Protocol: _tcp
Port: 1688
Host offering the service: serverip.domain.com

If you have checked eveything here, please contact your kms admins, the IP you are trying to activate your windows 7 might be blocked by a firewall.

Hope this helps.
0
 
Joel ParmerAuthor Commented:
It turns out that the issue was the date was a day off on the machine.

As soon as I corrected that, it activated against KMS.
0
 
Joel ParmerAuthor Commented:
After looking at the KMS server event logs and seeing the failure code their, I searched Microsoft's site which gave the answer about the time being off.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now