Some ACT fields grayed out

Hello Experts,

I am using ACT 2009 Premium by Sage v. 11.0
Some of the fields in the company layout and some tabs are grayed out. I cannot run a search on them. I cannot enter values into the fields and the data that used to be there has disappeared. It's almost as if these particular fields have been locked. I checked the security settings and it's set to Full Access.
I did not create this layout or the fields. The db was designed by an admin that's no longer with the company.
We have few other layouts and I am not seeing this on any other layouts.
I've attached two jpeg images with the grayed out fields highlighted. In the company layout, only some of the fields are grayed out but in the tab, all the fields are grayed out.

I would appreciate any solutions, suggestions, recommendations anyone can offer.

Who is Participating?
Mike LazarusConnect With a Mentor Act! Evangelist - CRM ConsultantCommented:
Fields don't just disappear from a database ... no matter how it's copied.

If you have multiple databases with different fields, then maybe the wrong layout was copied at some time ... or maybe those fields were deleted without being removed from the layout - you might want to remove them now (after backing up) to prevent the confusion in the future
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Have you tried using a different layout?
PushtiLeelaAuthor Commented:
Each layout has different set of tabs and fields. I have tried different layouts but then I cannot see the  tabs or fields that are in this layout. This is the only layout we have this problem with.
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Try editing the layout to see if the fields show there
PushtiLeelaAuthor Commented:
I've tried that. They show there. I've made minor adjustments, for ex. changing the size of the field, but they still remain grayed out. I deleted one of the fields to see if re-entering it would change anything. But when I went to add it back, I wasn't able to find that field in the selection. It seems as if all these grayed out fields have been deleted from the database but not from the layout. Can that be possible?
It is possible that the Database fields have un-linked from the fields displayed on the layout.
Can you try the following?
1. Select Tools > Design Layouts > Contact
2. Press F4 on your keyboard to bring up the properties window (Or select View > Properties Window)
3. Select one of the fields that is greyed out on the layout (Be sure to select the field and not the label)
4. In the Properties window there should be a Data area with a property called 'Field Value'

If the field is not blank then please take a screenshot of the properties and post it back as a comment as this may assist in the investigation of this issue.

If the field value is blank click the box and then select the drop down list, pick the field that should be displayed in the box and select it. Once you have selected the field save the layout (File > Save) and exit the layout designer, the field on the main ACT! screen should now be usable.

PushtiLeelaAuthor Commented:
I checked the field value for all the grayed out fields. It's blank for all of them.
I checked the server to see if any other databases exist. I found another database. Both db were created before I joined the company but it seems the current db was incorrectly copied from the older db. I am not sure how or why this would have happened.

I tried to log in to the older db using an older user's credentials to see if these grayed out fields are accessible but I get an error.
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Try logging into the database while on the server.

Also, can you confirm that you're an Administrator in the database?
If the Field Value box is empty, click in the box - this should show a drop down arrow as if it was a drop down list.
In that list should be all your field names, do any of the fields in the drop down list correspond to the field that is grey?
If so select the field and save the layout, this should re-activate the field.

Sometimes copying a database causes the custom fields to drop out of the layout, re-adding them through the field value box and saving should tie them back up again (assuming the fields still exist).
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
another option ... copying the database often doesn't copy the layout at all. So, it's possible that this layout is the wrong one and copying in the right layout (that is looking at the right fields) might fix the issue faster.

Have you checked in Define Fields that they missing fields are in the database you're looking at?
PushtiLeelaAuthor Commented:
None of the grayed out fields are available in the drop-down selection. I checked every single one of them.

I have checked in the Define Fields and they are missing there as well.

Fortunately I've just informed not to worry about previously entered data for these missing fields. I want to prevent this from happening to our currently active db.
Can you suggest how one would copy from one db to another & prevent this from occurring?
PushtiLeelaAuthor Commented:
I think that might've been the case. The wrong layout was copied over. Thank You.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.