Solved

Some ACT fields grayed out

Posted on 2013-01-14
12
2,268 Views
Last Modified: 2013-01-17
Hello Experts,

I am using ACT 2009 Premium by Sage v. 11.0
Some of the fields in the company layout and some tabs are grayed out. I cannot run a search on them. I cannot enter values into the fields and the data that used to be there has disappeared. It's almost as if these particular fields have been locked. I checked the security settings and it's set to Full Access.
I did not create this layout or the fields. The db was designed by an admin that's no longer with the company.
We have few other layouts and I am not seeing this on any other layouts.
I've attached two jpeg images with the grayed out fields highlighted. In the company layout, only some of the fields are grayed out but in the tab, all the fields are grayed out.

I would appreciate any solutions, suggestions, recommendations anyone can offer.

-Nancy
ACT-grayed-out-fields2.JPG
ACT-grayed-out-fields1.JPG
0
Comment
Question by:PushtiLeela
  • 5
  • 5
  • 2
12 Comments
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 38774545
Have you tried using a different layout?
0
 

Author Comment

by:PushtiLeela
ID: 38774580
Each layout has different set of tabs and fields. I have tried different layouts but then I cannot see the  tabs or fields that are in this layout. This is the only layout we have this problem with.
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 38774589
Try editing the layout to see if the fields show there
0
 

Author Comment

by:PushtiLeela
ID: 38774626
I've tried that. They show there. I've made minor adjustments, for ex. changing the size of the field, but they still remain grayed out. I deleted one of the fields to see if re-entering it would change anything. But when I went to add it back, I wasn't able to find that field in the selection. It seems as if all these grayed out fields have been deleted from the database but not from the layout. Can that be possible?
0
 
LVL 7

Expert Comment

by:50cal
ID: 38775281
It is possible that the Database fields have un-linked from the fields displayed on the layout.
Can you try the following?
1. Select Tools > Design Layouts > Contact
2. Press F4 on your keyboard to bring up the properties window (Or select View > Properties Window)
3. Select one of the fields that is greyed out on the layout (Be sure to select the field and not the label)
4. In the Properties window there should be a Data area with a property called 'Field Value'

If the field is not blank then please take a screenshot of the properties and post it back as a comment as this may assist in the investigation of this issue.

If the field value is blank click the box and then select the drop down list, pick the field that should be displayed in the box and select it. Once you have selected the field save the layout (File > Save) and exit the layout designer, the field on the main ACT! screen should now be usable.

50cal.
1
 

Author Comment

by:PushtiLeela
ID: 38776042
I checked the field value for all the grayed out fields. It's blank for all of them.
I checked the server to see if any other databases exist. I found another database. Both db were created before I joined the company but it seems the current db was incorrectly copied from the older db. I am not sure how or why this would have happened.

I tried to log in to the older db using an older user's credentials to see if these grayed out fields are accessible but I get an error.
ACT-login-error.JPG
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 38776075
Try logging into the database while on the server.

Also, can you confirm that you're an Administrator in the database?
0
 
LVL 7

Expert Comment

by:50cal
ID: 38776130
If the Field Value box is empty, click in the box - this should show a drop down arrow as if it was a drop down list.
In that list should be all your field names, do any of the fields in the drop down list correspond to the field that is grey?
If so select the field and save the layout, this should re-activate the field.

Sometimes copying a database causes the custom fields to drop out of the layout, re-adding them through the field value box and saving should tie them back up again (assuming the fields still exist).
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 38776165
another option ... copying the database often doesn't copy the layout at all. So, it's possible that this layout is the wrong one and copying in the right layout (that is looking at the right fields) might fix the issue faster.

Have you checked in Define Fields that they missing fields are in the database you're looking at?
0
 

Author Comment

by:PushtiLeela
ID: 38776513
None of the grayed out fields are available in the drop-down selection. I checked every single one of them.

I have checked in the Define Fields and they are missing there as well.

Fortunately I've just informed not to worry about previously entered data for these missing fields. I want to prevent this from happening to our currently active db.
Can you suggest how one would copy from one db to another & prevent this from occurring?
0
 
LVL 30

Accepted Solution

by:
Mike Lazarus earned 500 total points
ID: 38776528
Fields don't just disappear from a database ... no matter how it's copied.

If you have multiple databases with different fields, then maybe the wrong layout was copied at some time ... or maybe those fields were deleted without being removed from the layout - you might want to remove them now (after backing up) to prevent the confusion in the future
0
 

Author Comment

by:PushtiLeela
ID: 38787225
I think that might've been the case. The wrong layout was copied over. Thank You.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Introduction: I have seen many questions on EE and elsewhere, asking about how to find either gaps in lists of numbers (id field, usually) ranges of values or dates overlapping date ranges combined date ranges I thought it would be a good …
Using SQL Scripts we can save all the SQL queries as files that we use very frequently on our database later point of time. This is one of the feature present under SQL Workshop in Oracle Application Express.
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now