Solved

Deleting / Re-creating User Account with Exchange Mailbox

Posted on 2013-01-14
11
434 Views
Last Modified: 2013-01-29
I have a user that cannot send or receive external e-mail but can for internal e-mail. The environment is Microsoft Exchange 2003 on Windows Server 2003. There is only one server running Exchange. Nobody else is having this problem. Here is my question:

I want to delete and re-create the user account. What happens to his mailbox?
What is the best way to backup and restore the mailbox?

Thank you for your help!

Dan
0
Comment
Question by:MusicMan440
  • 6
  • 2
  • 2
  • +1
11 Comments
 
LVL 12

Expert Comment

by:aindelicato
ID: 38774699
The mailbox would be orphaned.  You can reattach the mailbox after you recreate the user account.
0
 

Author Comment

by:MusicMan440
ID: 38774712
Thanks! Should I make sure not to create a new mailbox when I re-create the user account?
0
 
LVL 12

Expert Comment

by:aindelicato
ID: 38774721
Correct.  Just create a new account.  Then reattach the mailbox to that account.
0
 
LVL 4

Expert Comment

by:mprssjpr
ID: 38774727
aindelicato is correct. However be aware that in 2003, actions such as this can take some time to complete. If you are on a tight schedule, you might find yourself sitting around while it does so. What you don't want to happen is that when you go to create the user again, it tells you they already exist, even if they are no longer in the list.

It might be better to create a completely fresh AD account for the user, with a slightly appended name, e.g. fred.bloggs1, disconnect the old mailbox, then attach it to the new user account (remembering to disable the old account).

Manually check that all settings in the properties of the new user (email addresses, log on name, account name etc) are correct.

This may work for you - it may not. If it doesn't, the problem is clearly with the mailbox.

However - before you do all this - what actually happens when this user attempts to send external email? It may just be a setting...
0
 

Author Comment

by:MusicMan440
ID: 38774737
Nothing happens, no NDRs are reported at all. The SMTP queue is clear. Is there a permission that effects external mail somewhere that I should check?
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 19

Expert Comment

by:R--R
ID: 38774748
Take a backup of the mails in PST. Remove the mailbox and then recreate it.
Or only remove the mailbox and recreate it.
0
 
LVL 4

Expert Comment

by:mprssjpr
ID: 38774768
Well, I'd first check in the properties of the user that their email address is correct.

Next, check that no policies are defined to restrict sending or receiving for particular users. See this article for more info: http://support.microsoft.com/kb/924635

As R-R says, you can't be too careful, so if you do end up disconnecting and reconnecting the mailbox, maybe do a .pst as well. Or, as they say, make an entirely new user (with mailbox), log on as them, and bring in the .pst. The best way I've found of doing that is to add it as an additional one, then when showing and expanded in Outlook, copy mail folder by folder back into the Exchange mailbox.
0
 

Author Comment

by:MusicMan440
ID: 38775630
Thanks for the help, I will back up the e-mails first as a CYA standard, then I will recreate the mailbox and report back once finished..
0
 

Author Comment

by:MusicMan440
ID: 38782737
Okay here are some of the things I tried with no luck:

1. Disconnect and reconnect user's mailbox
2. Delete user mailbox, and create new mailbox from scratch
3. Disable and re-enable user account

I used telnet to port 25 and was able to send a message on the user's behalf to myself but he is still not receiving external e-mail.

I guess the only thing left at this point is to delete and create a whole new user account, unless anyone has any other suggestions..
0
 

Accepted Solution

by:
MusicMan440 earned 0 total points
ID: 38814543
I figured it out. Their ISP had a Sonic Wall SPAM filter and the MX records were pointing to that. Problem was that it was blocking a lot of e-mail from coming through. Thanks for all of the help regardless.
0
 

Author Closing Comment

by:MusicMan440
ID: 38830299
I investigated and saw in the SMTP logs that a lot of e-mail was being sent to a SPAM filter which was housed at their ISP. I had their ISP remove the filter MX record and now e-mail is being received.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now