• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1496
  • Last Modified:

The previous webpage wants to run the following add-on


How do I set "allow on all webpages" to "the previous webpage wants to run the following add-on Java..." in Internet Explorer?

I have to deploy it to our computers-.. so script/registry/bat... whatever... (not using GUI)

Thanks in advance

2 Solutions
mikeydk--I do not do code, but this may help someone develop the Group Policy

Is the word "previous" really in that message?
Dave BaldwinFixer of ProblemsCommented:
I have never heard of "the previous webpage wants to run the following add-on Java..." either.  Make sure that the version of Java is updated to the one released yesterday to fix a serious error.
mikeydkAuthor Commented:
the previous webpage wants to ....
Just showing Java insted...
7 new features that'll make your work life better

It’s our mission to create a product that solves the huge challenges you face at work every day. In case you missed it, here are 7 delightful things we've added recently to monday to make it even more awesome.

Dave BaldwinFixer of ProblemsCommented:
I don't understand you comment, "Just showing Java insted..." unless you mean that it is a different page instead of the image shown.  Before allowing it, I would find out where it is coming from and whether it is supposed to be there.
David Johnson, CD, MVPOwnerCommented:
I hope that you are WELL aware that JAVA is severely compromised and that there are several malicious scripts floating around the web.  The US Department of Homeland Security has issued a warning and advised everyone to disable JAVA in their web browsers even if you've downloaded yesterdays patch/update to 7.11

Kaspersky Lab estimated that last year 50% of all website exploitations were due to vulnerabilities in Java. Adobe's Acrobat Reader accounted for another 28% of vulnerabilities  (that's 78%, leaving only 22% for Microsoft and other vulnerabilities)

The Citrix addon you mentioned  is not a java addon but an active-x addon

From Citrix:
Add your Web Interface site to the Trusted Sites within Internet Explorer with the Default security settings for this zone. This allows the downloading and running of the ActiveX Controls required by the Web Interface Site to run properly.

Disabling or changing security settings from the default for ActiveX in this zone might cause the required ActiveX control not to run
mikeydkAuthor Commented:
When using IE9 + Java 1.7.x

Windows Registry Editor Version 5.00





Open in new window

mikeydkAuthor Commented:
Correct answer
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now