Exchange 2007 SP1 not recieveing mail Event ID 4999 5000 & 7031 EdgeSync Crashes.

Hi,

After an automatic update last night (14/01/13), my email server stopped recieving and processing mail. It seems that the EdgeSync serive is constantly crashing. I have tried removing the updates, but it hasn't worked. I cannot do anything in the Exchange Console or Command Shell.

I am running Windows 2003 Server and Exchange 2007 SP1, it is the only exchange server in the organisation.

In the event logs I get the following 3 errors repeatedly, please help!:

--------------------------------------------------------------------------------------------------------------------------

Event Type:      Error
Event Source:      MSExchange Common
Event Category:      General
Event ID:      4999
Date:            14/01/2013
Time:            18:19:04
User:            N/A
Computer:      EXCHANGE
Description:
Watson report about to be sent to dw20.exe for process id: 4928, with parameters: E12, c-RTL-AMD64, 08.01.0436.000, M.E.EdgeSyncSvc, S.Configuration, S.C.ConfigurationSchemaErrors.ThrowIfErrors, S.Configuration.ConfigurationErrorsException, 1ac1, 02.00.50727.3053.  ErrorReportingEnabled: True

---------------------------------------------------------------------------------------------------------------------------

Event Type:      Error
Event Source:      Microsoft Exchange Server
Event Category:      None
Event ID:      5000
Date:            14/01/2013
Time:            18:19:04
User:            N/A
Computer:      EXCHANGE
Description:
EventType e12, P1 c-rtl-amd64, P2 08.01.0436.000, P3 m.e.edgesyncsvc, P4 s.configuration, P5 s.c.configurationschemaerrors.throwiferrors, P6 s.configuration.configurationerrorsexception, P7 1ac1, P8 02.00.50727.3053, P9 NIL, P10 NIL.

-----------------------------------------------------------------------------------------------------------------------------

Event Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7031
Date:            14/01/2013
Time:            18:24:58
User:            N/A
Computer:      EXCHANGE
Description:
The Microsoft Exchange EdgeSync service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.
gabioszAsked:
Who is Participating?
 
gabioszConnect With a Mentor Author Commented:
OK, anyone having to repeat this fix, having uninstalled the KB2756918 update, please remember to revert the machine.config in both the C:\Windows\microsoft.net\framework\V2.0.50737\Config\ AND C:\Windows\microsoft.net\framework64\V2.0.50737\Config\ . You can do this by renaming the original file to machineconfig.old and copying  machine.config.default and renaming it to  machine.config. Then restart.
0
 
AmitIT ArchitectCommented:
I suggest you to  upgrade Exchange 2007 SP3 RU9
0
 
gabioszAuthor Commented:
I'm afraid it will not let me update anything, I initially tried reinstalling rollup 10, and the SP3, but it fails with an installation error. I'm really stuck!
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Edge Sync service is required if you have EDGE servers and work with them Stop and ensure all others are started

Run EXBPA

- Rancy
0
 
gabioszAuthor Commented:
0
 
AmitIT ArchitectCommented:
That's why we should keep auto update to disable state and apply only fix related to Exchange, if required.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Woops ..... hope this can fix your issue as well if not plan for a .Net update that might help as well

- Rancy
0
 
gabioszAuthor Commented:
Found fix elsewhere.
0
 
bjohnsontaCommented:
gabiosz:

Thank you.  Your recommendation worked for me too.   I uninstalled KB2756918 and followed your the instructions.   I have Exchange 2007 with SP2 and update Rollup 5.

My paths were slightly different, but it worked like a champ.

C:\Windows\microsoft.net\framework\V2.0.50727\Config\ AND C:\Windows\microsoft.net\framework64\V2.0.50727\Config\
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.