SQL - Exception of type System.OutOfMemoryException was thrown

Once in awhile, checking SQL Integrity Check logs, I get this error.

Re-saving the job usually fixes it.  Or deleting it and re-adding it fixes it as well.

Anyone know why this is?
LVL 1
SoftwareMarketingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lcohanDatabase AnalystCommented:
Not knowing what SQL version/edition/service pack are you using it makes it a bit more dificult to tie it to a exact match however - did you checked this article allready?

http://support.microsoft.com/kb/909678
0
SoftwareMarketingAuthor Commented:
Thats SQL 2000.

I'm sorry this happens on both 2008 and 2008 r2 SQL on both Windows 2008 and 2008 r2.  Both having the latest service packs.
0
lcohanDatabase AnalystCommented:
"Once in awhile, checking SQL Integrity Check logs, I get this error."


Can you post the actual error you are getting?

Did you checked SQL Logs and Event Viewer to see if there are any errors? What about SQL Agent Log and job history? Do they report anything unusual?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

SoftwareMarketingAuthor Commented:
I posted a picture.
0
lcohanDatabase AnalystCommented:
Sorry but I can't see any picture....
0
SoftwareMarketingAuthor Commented:
The error is in the title as well.

Exception of type System.OutOfMemoryException was thrownError message
0
lcohanDatabase AnalystCommented:
It may be that a large record set or some cartesian set from a poorly written query is causing it. Regardles please see details about mem config as recommended by Microsoft at link below:

http://msdn.microsoft.com/en-us/library/ms177455.aspx

“For 64bit systems, the virtual address space limitation is not an issue. However, if an application wants to "lock its memory" or avoid its working set from being trimmed, then it can achieve this by using the AWE APIs. Again, in order to use these APIs, you must have the 'lock pages in memory' privilege set. This is why for 64bit systems, you don't need to set the 'awe enabled' option to 1 (it is actually ignored on 64bit systems).”
We don’t enable AWE but lock pages in memory MUST be set for the account running SQL Server service in order to be able to use the extended above standard 4kb pages. I think that should clear the error message from SQL log and please read http://blogs.msdn.com/b/psssql/archive/2009/06/05/sql-server-and-large-pages-explained.aspx for more info.


http://support.microsoft.com/kb/319942/en-us

There is a great article about SQL Express idle time memory usage in this blog article: http://blogs.msdn.com/b/sqlexpress/archive/2008/02/22/sql-express-behaviors-idle-time-resources-usage-auto-close-and-user-instances.aspx (this article also details some other interesting facts about Express edition).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.