?
Solved

No "www." for Web Site

Posted on 2013-01-14
7
Medium Priority
?
300 Views
Last Modified: 2013-01-20
Hello, Experts!  I have multiple web sites with multiple Internet domains on a single Windows 2003 Server with IIS.  

If you type in "www." before each domain in a web browser, the default index.html page loads fine.  However, if you just type "domainA.com", the default page doesn't come up but with "domainB.com" it does.

The domains are registered with Network Solutions.  I checked the DNS settings for each domain in our account.  The "@none" is set to the same IP as "www" for both sites so I'm starting to think this is an IIS problem.

In IIS, there is one site for each domain as well. Each has the "www.domainX.com" and "domainX.com" Host Header Values set to the same internal address.  Both domains have their respective index.html home files.

What I can't seem to find is the area where IIS is told to load index.html if no page is specified -- assuming that's the same area where I can configure it to load index.html for "domainA.com" without "www.".

Hopefully that makes sense.
0
Comment
Question by:wchestnut
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 16

Expert Comment

by:choward16980
ID: 38776711
0
 

Author Comment

by:wchestnut
ID: 38776731
Yes, already been there, checked that.  All related IP addresses are the same for both domains for "www" and "@ (none)" under their Advanced DNS.
0
 
LVL 9

Expert Comment

by:the_b1ackfox
ID: 38776766
Add another binding

You should have one for domain name and www.domain name! ;)
0
Get MongoDB database support online, now!

At Percona’s web store you can order your MongoDB database support needs in minutes. No hassles, no fuss, just pick and click. Pay online with a credit card. Handle your MongoDB database support now!

 
LVL 9

Expert Comment

by:the_b1ackfox
ID: 38776774
Oh yeah, and website, rt click properties -> documents for setting default page
0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 38777159
Check your websites on IIS to confirm if host headers are enabled.
If yes then you'll need to add the domain without the www. as well.
0
 

Accepted Solution

by:
wchestnut earned 0 total points
ID: 38778978
Sorry, guys... I'm an idiot.  This was only happening from within our LAN.  It's not happening outside of our network.  Both domainA.com and domainB.com work without the www.  I need to change the internal DNS.
0
 

Author Closing Comment

by:wchestnut
ID: 38798072
This wasn't a problem outside on the Internet, only from within our own LAN.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question