Solved

Terminal Services - Windows 2003 Server ent SP2

Posted on 2013-01-15
7
497 Views
Last Modified: 2013-01-23
Hi,

i. Windows Server 2003 Standard Edition SP2 - Domain Controller and TS license server
ii. Windows Server 2003 Enterprise Edition SP2 - Member Server and Terminal Server


I have a path set under the Terminal Services Profile tab in AD (i) to save the users Terminal Services profile to an external drive. This work fine and the users TS profile is saved to the correct path.

However when the user logs onto the TS (ii). The users profile is also created on the C:/ drive of the Terminal Server (ii)

In essence I have 2 of the same profiles, one on the external drive and the other on the local C:/ drive of the Terminal Server.

Is there a reason for this to happen, 2 replicating profile folders in different locations?

I know I could possibly create a GPO and redirect some folder items in the profile folder on the C:/ drive to the external drive but is there another way to do this?


Many Thanks
0
Comment
Question by:markbenham
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 84

Expert Comment

by:oBdA
ID: 38777914
Yes, that's perfectly normal. The path in the Terminal Services Profile tab in AD specifies a "Roaming Profile", which is supposed to be on a network location so that the user can "roam" from one machine to another while using the same profile.
The roaming profile will be cached locally from the network location to the default user profile when the user logs on, and be written back when the user logs off.
If you want to reduce the profile size on the terminal servers, redirecting the user's folders is the right way to go.
Note: do not redirect the folders to a location in the user's roaming profile folder!
0
 

Author Comment

by:markbenham
ID: 38779918
Hi ,

Many thanks for you response.

The user profiles folders are now redirected using GPO's. I've also done a gpudate (to the extent of a reboot), however the users profile folders are still caching on the local drive of the TS even when the user logs off.

Any ideas why this is happening?

Many Thanks
0
 
LVL 84

Expert Comment

by:oBdA
ID: 38780032
The user profile consists of more than the folders you can redirect. The rest of the profile folders will still be cached locally on the machine where the user is logging on. This can not be prevented.
You can set a group policy to delete the local cached on logoff, but this doesn't make sense if you only have one terminal server.
If the folders containing user data are redirected (especially My Documents and Desktop), then the rest that is still synced shouldn't be too big.
0
Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

 

Author Comment

by:markbenham
ID: 38780302
Hi

I understand and by right that should be the case, however it is also caching the "My Documents, Desktop and Application Data" folders on the local drive of the TS server.

So not only is there a GPO to redirect  the "My Documents, Desktop and Application Data" folders and this works, the same folders are also saved to the local drive of the TS.

Really strange and not sure what to do now....


Many Thanks
0
 
LVL 84

Expert Comment

by:oBdA
ID: 38780768
You did read my note about not redirecting these folders into the roaming profile folder?
Best/easiest solution is usually to redirect them into the user's home drive.
0
 

Author Comment

by:markbenham
ID: 38784907
yup I did and its not being redirected into the roaming profile folder.

>> Best/easiest solution is usually to redirect them into the user's home drive

Apologise - Not sure I understand what you mean by this.

I need to be able to remove the users profile from the C:/ drive of the Terminal Server.

Strange as to why it doesn't remove the cache when the user logs out....

Many Thanks
0
 
LVL 84

Accepted Solution

by:
oBdA earned 500 total points
ID: 38785027
By default, the cache will not be deleted, because it saves time when the user logs on the next time. But as I said: you can apply a GPO to the TS and enable deletion of the cache on logoff.
You should find it under Computer Configuration\Administrative Templates\System\User Profiles.
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question