Software Delpoyment using GPO

Here is what I have done so far.

.Created an OU called it test.
.Created a user, called him test.
.Put the user test in the Test OU.
. Created a folder & shared the folder with everyone full access (just to be on the safe side).
.Download .MSI file for a program called 7-Zip.
.Put the file into the folder that I created and shared.
.Crated a new GOP, called it deployed 7zip, edit the GPO ( see attached snap shoot )
. GPO Settings. On client workstation did a gpupdate /force
.The gpupdate says it was competed successfully & User policy update has completed successfully. What it dose not do is ask me to reboot for the GPO to take affect.

Needless to say I reboot and the GPO doe not install the 7-zip.msi file.

What I'm I missing?
checked, re-checked and checked again and still no joy.
Can anyone tell me what I'm doing wrong? From what I have read and seem it should not be difficult to get this running.

Thank you all
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

In the GPO editor, right-click the '7-Zip GPO Software' policy, and link it to the domain.
Unless I am mistaken the GPO needs to be applied to the OU the Computer is in rather than the OU the User is in...
Please try to Set the Group Policy setting under Computer Configuration -> Administrative Templates -> System ->  Logon -> Always wait for the network at computer startup and logon to Enabled.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

noadAuthor Commented:

Why the domain GPO, I want it to go to a specific OU. I don't want it to apply to everyone.

can you explain?

noadAuthor Commented:

I have applied both the computer and user to the test OU.
see the snap shoot. maybe I did it wrong? Can you take a look and verify for me?

Noad - yes, I know it seems illogical, but that's how it works. When you right click it, and choose 'Link Enabled' and 'Enforced', you will see in the main pane that another item appears, with the name of the domain.

You will see in that columns of the main pane that the object is NOT enforced for the domain, only for the OU. If you don't link to the domain, the object is kind of...orphaned.
noadAuthor Commented:

do you mean to setup a GPO in the test OU and give it those settings?

If that is what you mean, I did it and still no joy, noting seems to be working!
I still can't see what I'm doing wrong...
Joseph MoodyBlogger and wearer of all hats.Commented:
Read this to help troubleshoot the GPO:

The picture shows the software on the computer side. If so, you must have that linked to an ou containing computers.

You also don't need to list the computers and authenticated users on the security scope. Authenticated Users is every authenticated object (computers and users).
noadAuthor Commented:

ok, I understand what you are saying, not sure exactly how to do it...
Can you plz explain it to me in more details.
Not thinking stright
noadAuthor Commented:

So you are saying to include or move the computer into the test OU?
Joseph MoodyBlogger and wearer of all hats.Commented:
mprssjpr is wrong. The GPO can be linked to an OU specifically. It does not need to be enforced or link to the domain as well.
Joseph MoodyBlogger and wearer of all hats.Commented:
From your picture, you have the MSI loaded in Computer Config\Software Installation. Because of this, the GPO must apply to a computer. If you have the GPO linked to Test OU and the GPO applies to Authenticated Users, then a computer will need to be in the Test OU as well.

The user can be in any OU.

After moving the computer, restart once (because you moved the computer object). Restart once more (so that the GPO can be downloaded). Restart once more so that it can be applied.

You can also cut these restarts down by enabling "Always wait for the network at computer startup and logon". ComputerConfig\Admin Templates\System\Group Policy
The Computer account needs to be in the Test OU.
noadAuthor Commented:
I understand what you are saying.
My primary JOB is as a Paramedic on a Fire Dept.
I'm going on a call now, bit Willie PC to test OU and try it out ASAP

Thanks all
noadAuthor Commented:

I tested what you explain and it did not work, here is what I did.
I added the computer to the test OU and removed the GPO link from the domain.
No joy, I added the GPO link back to the Domain and it worked.
I did this second test with a different computer.

While I more then agree with you that I should be able to set the GPO to different OU's, I must still be doing something wrong.

Any other ideas as to how I can correct it?

Joseph MoodyBlogger and wearer of all hats.Commented:
ok. Do this:

Link GPO back to Test OU only. On a client, run this command: gpresult /h Report.htm /f. Then right click on your GPO and select Save report.

Upload both files here.
noadAuthor Commented:
will do
noadAuthor Commented:

I ran the command and got noting, I ran gpresult -r and got the following.
I do see where the GPO is added and as per your input I removed the GPO link form the Domain GPO. I even installed Flash this way and it worked....
Now I'm working on uninstalling the 7Zip file via the GPO and will try the same with other work stations on the network.

GPO  ( gpresult -r )
Joseph MoodyBlogger and wearer of all hats.Commented:
If you go to C:\Users\Administrator, you can open the file named Report.htm

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
noadAuthor Commented:
WOW, I'm way off today...

Regardless, you are correct. I was able to deploy to a win8 computer on the network that's on a different OU.
I will look into getting the report..

Thanks for all of your help.
noadAuthor Commented:
Simple instruction to follow.
Joseph MoodyBlogger and wearer of all hats.Commented:
Not a problem!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.