Solved

Cisco 887 ATM0 intializing and down

Posted on 2013-01-15
12
1,616 Views
Last Modified: 2013-04-20
Hello Experts,
I have newly purchased Cisco 887 Router. I am trying to replace this router with the exisiting ISP provided modem I am facing an issue to bring the ATM0 port up.

My ISP modem is just accepting the ISP's username and password and giving the auto setting like IP,PVC info etc

Here is my router config

hostname Internet Router
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
no logging console
no aaa new-model

ip source-route
!
!
!
!
ip dhcp pool Internet_DHCP
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 4.2.2.2
 lease 0 6
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn FCZ1638C3GG
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
interface Ethernet0
 no ip address
 no fair-queue
!
interface ATM0
 no shut
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
interface Dialer1
 ip address negotiated
 ip access-group 101 out
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap chap callin
 ppp chap hostname XXXXXXXXXXXXXXXX
 ppp chap password 0 3920
 ppp pap sent-username XXXXXXXXXXXXXXXXXX password 0 3920
 ppp ipcp dns request
 ppp ipcp wins request
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
end

Please help to resolve this issue.

Thanks
0
Comment
Question by:cciedreamer
  • 7
  • 5
12 Comments
 
LVL 15

Expert Comment

by:max_the_king
ID: 38778929
Hi,
you probably need to set ppp over ATM and not ppp over Ethernet:

you should try the following (please be sure that pvc numbers are exact, your ISP should tell you):

interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1

interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication pap chap callin
 ppp chap hostname XXXXXXXXXXXXXXXX
 ppp chap password 0 3920
 ppp pap sent-username XXXXXXXXXXXXXXXXXX password 0 3920

that's all you should need, (i can't see what reference has the "ip access-group 101 out" in your config)

hope this helps
max
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38778988
Hi,
thanks for your quick response.
On my modem, after providing the username and password ( given by ISP) the release auto configuratio It shows pvc value as 0.200
i forgot to remove that access group.

Thanks
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38781576
I have configured the ATM interface as below but still not working I posting sh interface atm0 output as well

thanks for the help

interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/200
  encapsulation aal5mux ppp dialer
  dialer pool-member 1


ATM0 is initializing, line protocol is down
  Hardware is MPC/AOE ATMSAR, address is fc99.47d7.68f0 (bia fc99.47d7.68f0)
  MTU 1600 bytes, sub MTU 1600, BW 4608 Kbit/sec, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported
  Encapsulation(s): AAL5
  4 maximum active VCs, 1024 VCs per VP, 0 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
 


Samir
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 38781769
Hi,
i've never seen pvc 0/200, i believe you're using the wrong number.
You should check with your isp (they MUST tell you).
You may want to try pvc 8/35

max
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38781839
modemOn my ISP modem after provdiing the username and password I get connected here is the modem details i got from ISP.

Please see the attached.

Thanks
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 38781868
hi,
please try the following:

dsl operating mode ansi

max
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 3

Author Comment

by:cciedreamer
ID: 38781879
Hi,
Do you I to provide pvc or remove. what will be new configuration for ATM0 after adding dsl operating mode ansi.

Thanks for the help.
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38781890
Hi,
By the way my Cisco Router 887 is not supporting this command

dsl operating mode ansi.


Thank
0
 
LVL 15

Expert Comment

by:max_the_king
ID: 38782222
its under ATM configuration:

dsl operating-mode ansi

on 877 is supported, try

dsl operating-mode ?

and see the options

its independent from pvc
max
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38782231
I have a Cisco Router 887
I entered ATM0 interface configuration and after typing dsl operating ? It says unrecognized command.

Thanks for your time and help.
0
 
LVL 15

Accepted Solution

by:
max_the_king earned 500 total points
ID: 38782355
Router(config)# controller vdsl 0
Router(config-controller)# operating mode ansi
Router(config-controller)# end
Router#

if it doesn't work, please do me a favour, try and change pvc numbers:

as far as i know it can either be 0/35 or 8/35

max
0
 
LVL 3

Author Comment

by:cciedreamer
ID: 38782359
I shall try once I get back to my office and will let you know.

Thanks
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Wireless WAP School 4 54
pfSense IP Helper 4 92
SMB Routers with GB WAN 12 37
iPad Won't Connect 16 42
In this tutorial I will show you with short command examples how to obtain a packet footprint of all traffic flowing thru your Juniper device running ScreenOS. I do not know the exact firmware requirement, but I think the fprofile command is availab…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now