Solved

"Network Access was interrupted" error only on Windows 7 machine

Posted on 2013-01-15
8
1,928 Views
Last Modified: 2013-02-18
I have found several instances of this error online but the solutions don't work in this case:
(Facts)
The app is an Access 2003 app called MBScale.mdb
It is linked to a few tables in MBData.mdb on the same mapped drive.
The machine giving the error is new and only Windows 7 workstation.
Can open, run, compact and repair on other workstations but not on Win 7.
This workstation and others have Access 2007

I am unable to compact and repair the database from the Win 7 machine because it never lets me into the application MBScale after the error, it just closes.

I restored a backup of the database and renamed it MBScaleNew.mdb which worked fine.
I tried to delete MBScale.mdb from the Win 7 machine it tells me that the "file is in use". I went to the server and physically deleted the app MBScale and the associated .ldb. We restarted the server after this. Renamed the backup MBScale and we get the 'network access interrupted' error every time we try to run it from the Windows 7 system. Renamed the app back to MBScaleNew and it runs fine. User continued to use the MBScaleNew app for now.

A week later it happened again (we know why the network was physically disconnected and fixed that problem) this time with MBScaleNew. Even after deleting/renaming these app names, I have been unable to ever name the app MBScale or MBScaleNew.  If I run it or rename it from another workstation not Windows 7, it runs fine on those.  Now we are running MBScaleNew2.mdb because the Win 7 gives the error if I tried to name them either of the old names.  This has to be an issue with Win 7/Access 2007 on that new workstation.  It seems like the WS is not releasing the file even if we turn it off.  I've tried hotfixes from Microsoft and turning off SMB 2.0 in regedit with no change.  I tried copying the app to the local drive but it won't let me - says 'file in use'.  Those were solutions I tried so far that didn't work.  does anybody have any other ideas?
thank you. JR
0
Comment
Question by:cpoint-service
  • 4
  • 4
8 Comments
 
LVL 57

Expert Comment

by:Jim Dettman (Microsoft MVP/ EE MVE)
Comment Utility
<<Renamed the backup MBScale and we get the 'network access interrupted' error every time we try to run it from the Windows 7 system. Renamed the app back to MBScaleNew and it runs fine. User continued to use the MBScaleNew app for now>>

 This is the same DB, just renamed?  If so, I would look in the directory and see if there are any other files with the same base name. ie:

MBScale.mdw
MBScale.mdb

  That will cause all kinds of problems.

  Second thing; where is this installed?  If under the \Program Files or \Program Files (x86) directories, be aware that those directories have unique security and virtual redirects to other another directory.

 This prevents "Permission denied" errors when a non-admin use tries to write to these.

 Either:

1. Move the install to a directory off the root.

2. In the current install directory, set full security for every *AND* take ownership of the directory and any subfolders.  If you don't do this, Windows will still protect the directory and do a virtual re-direct.

 Last, make sure you turn off power down of the NIC and if it has any diagnostic protocols enabled, disable them (these will disconnect the NIC from the network, run a test, then re-connect it - nothing is supposed to notice when that happens, but....)

Jim.
0
 

Author Comment

by:cpoint-service
Comment Utility
There are no other files with other extensions by those names.  I deleted all files named MB_BeltScale.xxx and restarted the server.  when I restored that file by that exact name it gives me the error only on the windows 7 workstation.  The program is on a Data directory on a MS Server 2008.  It doesn't matter where the program is, it gives the error wherever it is.

Changed ownership/permissions on Server - made no difference.

Talked to our CNE and Service techs, power down option is disabled and we don't think it's a hardware issue.  It is a Windows 7 issue.
thanks anyway
0
 
LVL 57

Expert Comment

by:Jim Dettman (Microsoft MVP/ EE MVE)
Comment Utility
Hum.. I would try disabling SMB2 once again, but also OPLOCKS as well (which you can't do with SMB 2):

http://support.microsoft.com/kb/296264

 and see if that makes a difference.  Not sure it will.  I've re-read your question several times and can't help but feel I'm missing something...

Jim.
0
 

Author Comment

by:cpoint-service
Comment Utility
Thank you for the suggestions Jim but I disabled the registry settings you suggested above and it made no difference.  I'm out of options it appears.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 57

Expert Comment

by:Jim Dettman (Microsoft MVP/ EE MVE)
Comment Utility
Are these using mapped drives?  If so, please change the following:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

Note the current setting, then change it to -1

This disables autodisconnect of mapped drives.

Jim.
0
 

Accepted Solution

by:
cpoint-service earned 0 total points
Comment Utility
Microsoft helped find a solution.  It was a really long process to figure it out but basically by Disabling Offline Files in Win 7 Syc options unlocked the files. Leaving it off will keep Access from getting locked open databases in the future.

Hope this helps someone else because Microsoft was stumped for quite a while also.
thanks for the help.
Jean R.
0
 
LVL 57

Expert Comment

by:Jim Dettman (Microsoft MVP/ EE MVE)
Comment Utility
Thanks for posting that...and glad to hear the issue is solved.

Jim.
0
 

Author Closing Comment

by:cpoint-service
Comment Utility
Seemed like a very rare and new issue that stumped even Microsoft.  Tried several things but seemed unique to that computer's situation.

You probably won't find this easily so here's a solution:
Disabling Offline Files in Win 7 Syc options unlocked the files. Leaving it off will keep Access from getting locked open databases in the future.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This article is a continuation or rather an extension from Cascading Combos (http://www.experts-exchange.com/A_5949.html) and builds on examples developed in detail there. It should be understandable alone, but I recommend reading the previous artic…
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now