Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

IIS unable to browse default website

Posted on 2013-01-15
15
Medium Priority
?
826 Views
Last Modified: 2013-01-24
Working on an XP laptop, I'm trying to setup IIS to work with my team's web application.  But I'm unable to even browse the default website.  I get an Internal Server 500 error.  I get the same error if I browse the IISHelp resource, or try to select the default.htm file under IIS Help and right click/browse.

Is there some basic configuration missing?
0
Comment
Question by:jkavx
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 2
  • +2
15 Comments
 
LVL 84

Accepted Solution

by:
Dave Baldwin earned 800 total points
ID: 38780929
If you are running IIS on Windows XP, there is only the default website.  Did you see the default web page when you installed it?
0
 

Author Comment

by:jkavx
ID: 38780950
I didn't install it.  I was just given this laptop to work with.  When I run IIS, I see the Default Web Site, and under it the IISHelp resource.  I think that I should be able to right click and browse both of these, but get the 500 error.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 38780967
Are you running IIS on that machine or are you connecting to IIS on another machine?  '500' is the generic 'it didn't work' error.  And how are you 'running' IIS to see the Default Web Site and IISHelp resource?
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 

Author Comment

by:jkavx
ID: 38780974
On this machine.  From ControlPanel\Administrative Tools.
0
 

Assisted Solution

by:avachatv
avachatv earned 400 total points
ID: 38781049
One option would be to check access.
Click Start\programs\administrative tools\Internet Information Services\
Click on Default Web Site\
Click on Edit Permissions on right side or you can right click on your Default.htm -> go to properties and then File Security tab
Click Anonymous access and authentication control and on authentication methods page clear anonymous access.

Second option would be to reinstall IIS completely.
0
 
LVL 84

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 800 total points
ID: 38781086
I tried that on my computer and I got an error that the 'mmc' snap-in had an error.  I normally just open my web browser and put in the IP address of my computer and I don't have any problems.  Try that.  I'm not sure you're getting a regular or complete web browser with that method.
0
 

Assisted Solution

by:s0ni2
s0ni2 earned 400 total points
ID: 38781171
Hi,
 
For the MMC snap-in issue do below steps to troubleshoot.

 
   To explicitly enable an MMC snap-in in Microsoft Windows XP

    Click Start, click Run, type gpedit.msc, and then click OK.

    Expand User Configuration, and then expand Administrative Templates.

    Expand Windows Components, and then click Microsoft Management Console.

    Double-click Restricted/Permitted snap-ins, and then enable the setting for the MMC
    snap-in that you want to use.


Problem is with the PATH environment variable does not include the %SystemRoot%\System32\WBEM folder.


try fixit (http://go.microsoft.com/?linkid=9771194)

How do you know that IIS was installed properly?

The easiest way is to create an IIS console in MMC.

To create an IIS console in MMC

Click Start and Run, type mmc, and then click OK. This opens a blank console.



To add an IIS snap-in, click File and Add/Remove Snap-in.

Click Add.

Select Internet Information Services, and then click Add to add the IIS snap-in to the blank console. Once the snap-in is added, you can close the Add Standalone Snap-in dialogue box.

In the Add/Remove Snap-in dialog box, click OK.


Try IIS Cache Clear


Click "Start" on your server, open "Administrative Tools" and then open the "IIS" program.

Navigate to the website in IIS from which you want to remove the caching feature.

Right-click on your website, then click "Properties."

Click "Home Directory," click "Configuration," then click "App Mappings."

De-select the "Cache ISAPI Applications" box, then click "OK."




Last Option TRY  IISADMIN

link   http://iisadmin.codeplex.com/

Screen Attached


Then do  iisreset with no force ( Screen Attached )


Thanks,
Soni
image.png
image.aspx.jpg
0
 

Author Comment

by:jkavx
ID: 38781660
Is IIS installed correctlly?  I seemed to be able to create an IIS console in MMC.  But when I exited MMC and then reopened it, the IIS console I created was not there.  Should it have been there?
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 38781731
I have no idea what an IIS console is.  I do have IIS5.1 running on 4 different XP computers here without any troubles.  

Open your web browser.  Put 'localhost' in the address bar, press enter, and see if the local website shows up.  If it says something like 'No web site found', enter the IP address of your machine in your browser address bar and press enter.  One of those two methods should bring up your local web site if it is running.
0
 
LVL 5

Expert Comment

by:Dilip Patidar
ID: 38787024
Hello,

From the client machine:

ping domain
Works ?

telnet domain 80
Works ?

Test it from the client.

Thanks,

Dilip Patel
0
 
LVL 5

Assisted Solution

by:Dilip Patidar
Dilip Patidar earned 400 total points
ID: 38787031
Hello,

Do you know what user account the application is running under on the IIS?

Also you need to make sure the Virtual Directory is configured as an application under IIS before it will work with .Net.

Thanks and Regard's

Dilip Patel
0
 

Author Comment

by:jkavx
ID: 38789029
I've created a virtual directory.  But I'm unable to ping Domain.  I have local admin rights on the machine.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 38789250
Windows XP with IIS 5.1 only supports a single website.  It is much simpler and more restrictive than IIS 7 or 7.5.
0
 

Author Closing Comment

by:jkavx
ID: 38813417
Thanks for the feedback.  In the end, the problem was that this was a corporate laptop that did not have the corporate installation of IIS.  IIS had been installed from the MSDN XP iso.  Once installed from the corporate build, it behaved correctly.
0
 
LVL 84

Expert Comment

by:Dave Baldwin
ID: 38815824
Glad you found it and I didn't even know such a thing existed.
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Suggested Courses

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question