Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

redistribute eigrp into ospf

Posted on 2013-01-16
5
Medium Priority
?
761 Views
Last Modified: 2013-01-22
Hi,

I would like to redistribute my EIGRP routes into OSPF or RIPv2 network,  but i have classless and clasfull network in VLAN500, any idea about redistributing them ?


Cisco_3550#show run
Building configuration...

Current configuration : 3896 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CISCO_3550
!
enable secret 5 a
!
ip subnet-zero
ip routing
!
vtp domain TEST
vtp mode transparent
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan 500
!
interface GigabitEthernet0/1
 description Connected-to-CORE-1
 no switchport
 ip address 1.1.3.2 255.255.255.0
!
interface GigabitEthernet0/2
 description Connected-to-CORE-2
 no switchport
 ip address 2.1.3.2 255.255.255.0
!
interface GigabitEthernet0/3
 description Connected-to ABC
 switchport access vlan 500
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
!
interface Vlan500
 ip address 193.XXX.XXX.254 255.255.255.0
 ip address 193.XXX.XXX.254 255.255.255.0 secondary
 ip address 193.XXX.XXX.254 255.255.255.0 secondary
 ip address 10.10.3.254 255.255.255.0 secondary
 ip accounting output-packets
!
router eigrp 1
 redistribute connected
 redistribute static
 network 1.0.0.0
 network 2.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
0
Comment
Question by:ata1915
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 10

Accepted Solution

by:
mat1458 earned 500 total points
ID: 38782132
No problem, both RIPv2 and OSPF are able to handle subnet masks so just go ahead and redistiribute. Don't forget the subnets keyword in the redistribute EIGRP command in OSPF.
0
 
LVL 9

Assisted Solution

by:Sandeep Gupta
Sandeep Gupta earned 500 total points
ID: 38782299
into ospf

redistribute eigrp 1

into eigrp

redistribute ospf 1 match internal external 1 external 2

You can use routemaps to redistribute specific networks in OSPF & EIGRP
0
 
LVL 7

Assisted Solution

by:hau_it
hau_it earned 496 total points
ID: 38782579
All of the routing protocols you mention send the mask in the updates. So they are classless and you will not have any problem.
As i see you do not advertise vlan 500 networks. Any reason for that?
0
 
LVL 6

Assisted Solution

by:airwrck
airwrck earned 504 total points
ID: 38783707
You've been given redistribution configurations for eigrp into ospf.

For your vlan 500 networks, advertise the networks in ospf simply by

router ospf 1
 network 193.x.x.x 0.0.0.255 area 0
 network 193.x.x.x 0.0.0.255 area 0
 network 193.x.x.x 0.0.0.255 area 0
 network 10.10.3.0 0.0.0.0 area 0
 redistribute eigrp 1 subnets

Remember, that although ospf will advertise as many secondaries as you wish, it will only create neighbor relationships between primary IP addresses (not secondaries), so whatever neighbor you use has to be on that primary IP subnet.
0
 
LVL 1

Author Comment

by:ata1915
ID: 38808796
Thank you for the answer, sorry for the late response
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question