wss3.0 searching infopath form contents


I have a wss3.0 sharepoint site and would like to search for keywords stored in the 400 reports created with infopath stored on the site.

Is this possible or do I need foundation 2013 or is there a work around?

many thanks in advance
Who is Participating?
ukwebdzineConnect With a Mentor Author Commented:
The problem lay within rogue fields within the infopath form that was used to create the xml files in share point.

Field1 & field2 had huge amounts of junk data!!!

These have been removed from the form and now the infopath template is issuing new forms to sharepoint that are showing up in the search results with text previews.

I will now have to amend all the existing xml files to remove field1 and field2 (they are not required and not referenced in sharepoint at all)
Should be possible, if not you can always install the free Search Server Express 2008 with it.
ukwebdzineAuthor Commented:
For some reason it returns the results but with just a URL  - no text sample of the word found.

I tried installing SS Express 2008 but it failed with a non helpful error.

Basically it said an error occurred whilst installing SS Express 2008
All the prerequisites were met!

If I install search server on a different server I guess this would work ?
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

ukwebdzineAuthor Commented:
99% of my search results come out like this ??????? see below

I've been looking for an answer for weeks!!!!

290.XML is a infopath form with the word I searched for in it. Why is it showing the URL instead of content???


When you click on the xml file, does it open the InfoPath form?
ukwebdzineAuthor Commented:
ukwebdzineAuthor Commented:
ok, here is the XML header of a file 176.XML that has POM in the text.
When searching sharepoint it identifies the file as having the the word POM but only shows the file name 176.XML and no text preview.

<?xml version="1.0" encoding="UTF-8"?><?mso-infoPathSolution solutionVersion="" productVersion="12.0.0" PIVersion="" href="http://acalsharepoint/Technical%20reports%20infopath/Forms/template.xsn" name="urn:schemas-microsoft-com:office:infopath:Technical-reports--infopath-:-myXSD-2009-05-14T10-56-57" ?><?mso-application progid="InfoPath.Document" versionProgid="InfoPath.Document.2"?><?mso-infoPath-file-attachment-present?>

<my:myFields xmlns:xsi="" xmlns:xhtml="" xmlns:dfs="" xmlns:my="" xmlns:xd="" xml:lang="en-gb">

If I remove the lower section from this XML file and save it back to sharepoint then do a full crawl of the site. Then search for POM, sharepoint shows the text preview
ukwebdzineAuthor Commented:
Only problem is now I cant open the file 176.XML as it has errors!

Still no solution then
ukwebdzineAuthor Commented:
After working out that the problem lay within the infopath form I loaded the form and went through the fields with a fine tooth comb.

Deleting the fields not used in the form and then republishing the form

I solved it myself and it only took 3 months!!!!!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.