Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 974
  • Last Modified:

Attrib command

I am trying to use the Attrib to unhide the directory d:\users and all subfolders.

I entered attrib -h -s d:\users\*.* /s which I thought was the command, but it keeps displaying "File not found d:\users"
0
Mawallace
Asked:
Mawallace
1 Solution
 
ITguy565Commented:
Please try :


attrib -h -s foldername
where foldername is the name of the folder you are trying to change.
0
 
karunamoorthyCommented:
0
 
pony10usCommented:
I think what itguy565 is saying is to drop the "\*.*" after the d:\users so the command would be:

attrib -h -s d:\users /S /D (the "/D" processes folders as well as files)
0
 
MawallaceAuthor Commented:
Ok -

If I enter
attrib -h -s d:\users it unhides the d:\users directory.

But I want to unhide all subfolders of the d:\users direcotry. I thought that I entered
attrib -h -s d:\users\*.* /S in the past but I get File not found if I do!
0
 
pony10usCommented:
With the d:\users folder hidden the system can't "see" the folders within to set the attribute.  You could create a text file of the folders and create a script that loops through the text file to set each one or you can unhide d:\users and all sub folders then re-hide d:\users.  Haven't tried the last option so test it first.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now