MS Mouse and Keyboard Center keeps trying to download

Hello Experts,

I've been trying to find a setting or reason why Microsoft Mouse and Keyboard Center keeps trying to download software when it is already installed. Every morning when I boot my Windows 7 64-bit computer, I receive this window.

Download Window
Can anyone tell me how to disable this so I don't see it every morning or why it's doing it?
LVL 1
katredrumAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

katredrumAuthor Commented:
Wow I waited a whole day and no replies. I guess my question doesn't mean anything.
0
David Johnson, CD, MVPOwnerCommented:
It doesn't mean that at all, all it means is that an expert hasn't seen it yet.  use autoruns from sysinternals or msconfig and remove it from your startup..
0
MereteCommented:
Any updates is usually for a program installed on your system, so it's worth noting what is installed in your computer,  when you first get your system become familiar with all the programs running in the task manager. Check it often to see if anything has been added
since spyware is visible here viruses as well.
I discovered this program itype.exe  by checking my task manager, it seems a windows update updated driver for my keyboard and mouse and installed this software.
Check your program files or your task-manager for a service called itype.exe rightclick it and open file location.
itype servicesIn there is Microsoft Help open that and go to updates.
You'll see this>
 IntellitypeDo this
To turn automatic updating on or off
Click Start, Programs, Microsoft Keyboard, and then Quality Settings.
Microsoft Keyboard All Programs Start MenueTo turn automatic updating on, select Enable automatic updates, and then click OK.

To turn automatic updating off, clear Enable automatic updates, and then click OK.
 
 To update your software when you are prompted
Select Install the update now, and then click OK.
 
 To postpone updating your software until later
When you are prompted to install an update, select Remind me next week, and then click OK.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ded9Commented:
Just in case if the issue is still not resolved then try this

Make sure the keyboard and mouse are not connected to a usb hub ..connect them directly.

Connect them to another usb ports and check




Ded9
0
katredrumAuthor Commented:
Excellent! Thank you. Exactly what I was looking for!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.