IE 9 on Windows 7 pages hang on load

We have a Windows 7 Professional computer to is connected to a domain.

IE 9 is installed.  We can ping and tracert to sites without issue.  All the sites load in Chrome, but will sit there and hang and not load--maybe eventually after a few minutes. We have dumped the cache and that did not help.

What do you recommended?  Downgrade to IE 8 and re-downloaded and re-install IE9?

What else can we try as it seems to be IE, not the computer or network connection?
gta2011Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ded9Connect With a Mentor Commented:
User profile might be corrupted....create a new user account...reboot and then login under the new user account and check internet explorer.



Ded9
0
 
albeloConnect With a Mentor Commented:
You can start by disabling all addons (Tools -> Manage Addons).  Then try again.  If it works, then you know it's an addon that is causing the hang.  Narrow it down by turning on one addon at a time and testing.
0
 
gta2011Author Commented:
All addons are disabled.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jcimarronConnect With a Mentor Commented:
gta2011--You probably have seen this long thread on a similar problem.
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_27978135.html#a38781138
0
 
gta2011Author Commented:
Can anyone suggest anything else to try?  That thread fizzled out without a solution.
0
 
albeloConnect With a Mentor Commented:
Do you can Activex Filtering off or on?
0
 
Tony GiangrecoConnect With a Mentor Commented:
Check the managed add-ons you have in IE. You might want to disable the ones that load very slow. You also might have BHO's and multiple home pages which definately slows down IE.

Take a look at them, choose which ones to disable, eleiminate any double home pages and work quick again.
0
 
ded9Connect With a Mentor Commented:
Close all apps and then run this fixit

http://support.microsoft.com/mats/ie_performance_and_safety


Restart system and check.



Ded9
0
 
gta2011Author Commented:
Ded9: Did not help.
0
 
jcimarronCommented:
gta2011--Did you try the suggestions made in
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_27978135.html#a38781138   ?
They may not have worked for that person, but may help you.

http:#a38783700
0
All Courses

From novice to tech pro — start learning today.