Solved

Drupal 6: Module CKEditor installed, not working

Posted on 2013-01-16
9
407 Views
Last Modified: 2013-01-22
I have the WYSIWYG module isntalled, and I have tried uinstalling and reinstalling the CKEditor, but it never shows up in the list of modules available, although it is loaded to sites/default/modules/ckeditor.
0
Comment
Question by:hoagelby
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 12

Expert Comment

by:junipllc
ID: 38784634
Did you install the CKEditor library? You need that as well. You usually download it into sites/all/libraries and WYSIWYG will pick it up. See if there's a README file in the CKEditor module's directory itself. It might have more instructions than I can give off the top of my head :)

Good luck!

Mike
0
 

Author Comment

by:hoagelby
ID: 38784938
Yes, I did copy the expanded CKEditor into the libraries folder as it's own subdirectory (ckeditor). I will look for a readme file.
0
 
LVL 13

Expert Comment

by:Arrow_1
ID: 38784971
The WYSIWYG module is not yet compatible with v4.x of CKEditor. Use version 3.6.6 instead: http://download.cksource.com/CKEditor/CKEditor/CKEditor%203.6.6/ckeditor_3.6.6.zip
0
 
LVL 17

Expert Comment

by:nanharbison
ID: 38784995
Have you uploaded both the Drupal CKEditor module AND the ckeditor files from the link Arrow_1 shows above? You have to have both. The MODULE goes in the all/module folder and inside the ckeditor module folder is a folder called ckeditor, where you put the ckeditor files.
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Author Comment

by:hoagelby
ID: 38799478
I have installed CKEditor 3.6.6 and still it doesn't give me the Word-like buttons while editing a page. The modules seem to be loaded where they are supposed to be -- other modules are working OK.  Still no solution.
0
 
LVL 12

Accepted Solution

by:
junipllc earned 245 total points
ID: 38799632
Did you configure WYSIWYG with its profiles? The reason I ask is that you need to tell WYSIWYG to use CKEditor for each Input Format. If you don't know what I mean, try this:

Site configuration -> WYSIWYG profiles
Select CKEditor as the editor for the Input Format (say, Full HTML). Save.
Click 'Edit' to the right of the Input Filter name
Click on the fieldset for "Buttons and plugins."
Check the boxes for the buttons you want displayed.
Bonus: fool around with some of the settings in there. Some good configuration options in there

This does two things: tells Drupal to use CKEditor for the Input Format, and then sets up the buttons that are to be used with that Input Format. It would make no sense to have a button for embedded JavaScript in the Filtered HTML Format since it's not allowed. WYSIWYG allows you to configure each Input Format separately.

I hope this is the right track. If not, then do reply back :)

Mike
0
 
LVL 17

Expert Comment

by:nanharbison
ID: 38799641
Make sure you set the permissions to be able to use it.
0
 

Author Comment

by:hoagelby
ID: 38800968
This sounds promising. I won't be able to give it a try until the end of my regular work day (about 6 p.m. EDT).
0
 

Author Closing Comment

by:hoagelby
ID: 38807587
YES! It works! Thanks for the detailed instructions.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is for those that are having major problems with users upload files such as pictures to their profile. The solution is simple and has to do with correcting the directory paths. With some experimenting and testing i got it fixed. Note…
RTL (right to left) web applications aiming for audiences speaking languages like Hebrew or Arabic, are generally more complicated than the same applications aiming for audiences speaking Latin based languages. The main difference lies of course …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now