Solved

Exchange 2010 Autodiscover fails

Posted on 2013-01-16
8
601 Views
Last Modified: 2013-01-17
Setting up an Exchange 2010 box. We are using go-daddy for DNS. I have setup at godaddy the SRV records for autodiscover.
_autodiscover _tcp @ 0 0 443 emails.domain.com

When running the test on Microsoft Remote Connectivity Analyzer all the Autodiscover tests fail. I know Port 443 is open and forwarded because OWA is working. Not sure where to check from here.

Mike
0
Comment
Question by:PowerComputer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 18

Expert Comment

by:Sushil Sonawane
ID: 38784636
Please refer below link to configure auto discover service in exchange environment.

http://technet.microsoft.com/en-us/library/bb201695(v=exchg.141).aspx
http://www.petri.co.il/autodiscover-configuration-exchange-2010.htm


White paper to understand auto discover service.

http://technet.microsoft.com/en-us/library/jj591328(v=exchg.141).aspx
0
 

Author Comment

by:PowerComputer
ID: 38784662
I have done all those steps to no avail.
0
 

Author Comment

by:PowerComputer
ID: 38784730
When I run the test here is what I get

Attempting to contact the Autodiscover service using the DNS SRV redirect method.
      ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
             Test Steps
             Attempting to locate SRV record _autodiscover._tcp.DOMAIN.com in DNS.
      The Autodiscover SRV record was successfully retrieved from DNS.
             Additional Details
      The Service Location (SRV) record lookup returned host emails.genieservices.com.

       Attempting to test potential Autodiscover URL https://emails.DOMAIN.com/Autodiscover/Autodiscover.xml
      Testing of this potential Autodiscover URL failed.
             Test Steps
             Attempting to resolve the host name emails.DOMAIN.com in DNS.
      The host name resolved successfully.
             Additional Details
      


       Testing TCP port 443 on host emails.DOMAIN.com to ensure it's listening and open.
      The port was opened successfully.
       Testing the SSL certificate to make sure it's valid.
      The SSL certificate failed one or more certificate validation checks.
             Test Steps
             ExRCA is attempting to obtain the SSL certificate from remote server emails.DOMAIN.com on port 443.
      ExRCA successfully obtained the remote SSL certificate.
             Additional Details
      


       Validating the certificate name.
      Certificate name validation failed.
       Tell me more about this issue and how to resolve it

             Additional Details
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 

Author Comment

by:PowerComputer
ID: 38784736
I have not bought a SSL from go-daddy yet. But shouldnt this still work with just the self signed cert? If so do I need to somehow deploy the self signed cert?
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 500 total points
ID: 38784920
The self signed certificate isn't supported for use with Outlook Anywhere. You aren't going to pass any tests on the Microsoft site with a self signed certificate - as it is untrusted.

I suggest that you purchase the certificate first and then test again. The other option is to purchase a multiple domain certificate and use autodiscover A record rather than SRV records.

Simon.
0
 

Author Comment

by:PowerComputer
ID: 38784931
Simon,

I am looking at the certs on Go-Daddy right now. As far as I can see I will need a UCC good for 5 domains?

domain.com
emails.domain.com
autodiscover.domain.com

This will be good for Outlook Anywhere / OWA / and Activsynch?

Mike
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38785223
A 5 name certificate will be fine.
However don't put the root of the domain on the certificate or as the common name - no need. Set your preferred host name as the common name.

Simon.
0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
Suggested Courses
Course of the Month7 days, 13 hours left to enroll

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question