Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Outlook 2010 creating large OST for Fully Managed Mailboxes

Posted on 2013-01-16
9
Medium Priority
?
769 Views
Last Modified: 2013-04-22
I have a client who wants to be able to open and view employees mailboxes. In Exchange 2003 I simply gave him permissions and he could access the mailbox via OWA. When we migrated to Exchange 2010 on a 2011 SBS over a year ago I gave him Full Managed Access and he could again access the mailboxes at first through OWA and then with Outlook 2010 they showed up automatically.

Recently he received a new PC with the latest version of Outlook 2010 and it added these managed mailboxes to his local OST file making it huge. I unchecked caching shared mailboxes and still the OST includes all mailboxes. Not using Cache makes Outlook crawl because it is trying to be real-time to all the mailboxes.

How can I give him access to be able to open every mailbox without it creating a large OST? I need quick access to his Mailbox and occasional access to the others. Accessing them through Outlook 2010 or OWA is acceptable.
0
Comment
Question by:bm_alvarez
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +1
9 Comments
 
LVL 14

Expert Comment

by:BlueCompute
ID: 38785275
The cached mailboxes won't automatically be removed from the OST, you will need to blow it away and let Outlook build a new one.

Granting a user full access permissions on a mailbox won't normally cause it to be automatically opened in Outlook.  You should be able to simply grant permissions on all mailboxes, uncheck the 'cache additional mailboxes' and away you go.

Do the additional mailboxes show up in Outlook under the heading 'Managed Folders?
0
 

Author Comment

by:bm_alvarez
ID: 38785333
What you described is how it used to work but with Outlook 2010 SP1 there is an Auto Mapping feature for all Full Access Mailboxes. I did remove the OST file and had Outlook create a new one and it also included all the Full Access Mailboxes, this is with Cache Shared Mailboxes unchecked.
0
 
LVL 63

Accepted Solution

by:
Simon Butler (Sembee) earned 1200 total points
ID: 38786144
You can disable automapping using PowerShell. It requires Exchange 2010 SP2 and has to be done on each mailbox in turn:

Add-MailboxPermission "Shared Mailbox" -User -AccessRights FullAccess -AutoMapping:$false

Simon.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 14

Expert Comment

by:BlueCompute
ID: 38786971
Sorry for the incorrect info bm_alvarez...  every day's a school day!
0
 

Author Comment

by:bm_alvarez
ID: 38796830
When I try the PowerShell cmdlet I get an error: "A parameter cannot be found that matches parameter name 'Automapping'.

The command I entered was:
Add-MailboxPermission -Identity xxxxxx -User 'xxx xxxxx' -AccessRight FullAccess -Automapping $false
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 38798345
You should check that you are on Exchange 2010 SP2.
http://technet.microsoft.com/en-gb/library/hh135098(v=exchg.141).aspx

If not then you will have to update the server first.

Simon.
0
 

Author Comment

by:bm_alvarez
ID: 38815817
Updating Exchange 2010 to SP2 during this weekend's maintenance window. I will update this question after that maintenance is complete.
0
 
LVL 18

Expert Comment

by:Karen Falandays
ID: 39100295
I've requested that this question be closed as follows:

Accepted answer: 300 points for Sembee2's comment #a38798345

for the following reason:

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
One-stop solution for Exchange Administrators to address all MS Exchange Server issues, which is known by the name of Stellar Exchange Toolkit.
The viewer will learn how to simulate a series of sales calls dependent on a single skill level and learn how to simulate a series of sales calls dependent on two skill levels. Simulating Independent Sales Calls: Enter .75 into cell C2 – “skill leve…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question