Solved

Get-ExchangeCertificate comes back with error

Posted on 2013-01-16
13
2,134 Views
Last Modified: 2013-01-25
When I run Get-ExchangeCertificate from the Exchange Powershell, I get : Warning: An unexpected error has occurred and debug information is being generated: The process does not possess the 'SeSecurityPrivlege' privlege which is required for the operation.

When I run policytest.exe from the command line, it shows that I do.

It shows my DC server name, it shows the site name and it shows Right Found: "SeSecurityPrivlege"


I am at a loss. Other commands work fine. I ran Get-Mailbox, I ran Get-ExchangeServer and it works.

+ Get-ExchangeCertificate
+ ~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Get-ExchangeCertificate], Pri
   vilegeNotHeldException
    + FullyQualifiedErrorId : System.Security.AccessControl.PrivilegeNotHeldEx
   ception,Microsoft.Exchange.Management.SystemConfigurationTasks.GetExchange
  Certificate


Any ideas?
0
Comment
Question by:PatrickDoman
  • 8
  • 5
13 Comments
 
LVL 23

Accepted Solution

by:
Stelian Stan earned 500 total points
Comment Utility
Check to see if you have  KB2506146 and KB2506143 installed on your server. If you have them installed just remove them (http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx)
0
 
LVL 23

Expert Comment

by:Stelian Stan
Comment Utility
Also, are you running PowerShell as Administrator? If not just do that an try again.
0
 

Author Comment

by:PatrickDoman
Comment Utility
I am running as admin.
0
 

Author Comment

by:PatrickDoman
Comment Utility
I see them now. They are both in there.
0
 

Author Comment

by:PatrickDoman
Comment Utility
I removed the Framework 3.0 update. Still not working. Rebooting Server, we'll see if that helps.
0
 
LVL 23

Expert Comment

by:Stelian Stan
Comment Utility
sounds good. Done for today. Hope that fixes your problem.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:PatrickDoman
Comment Utility
That didn't do it, but I think you were on the right path.

Watson report about to be sent to dw20.exe for process id: 7816, with parameters: E12, c-RTL-AMD64, 08.03.0083.006, powershell, M.E.Net, M.E.S.C.X.TlsCertificateInfo.GetAccessRules, S.S.AccessControl.PrivilegeNotHeldException, c8c6, 08.03.0297.000.  ErrorReportingEnabled: False
0
 

Author Comment

by:PatrickDoman
Comment Utility
When I type in New-ExchangeCertificate i am getting another error.

New-ExchangeCertificate: Insufficient rights to grant Network Service access to the certificate with thumbprint ..........................
0
 

Author Comment

by:PatrickDoman
Comment Utility
I have an account called recovery on the server which I found had the Manage auditing and security log right.

I logged in as that user, and I can run the Get-ExchangeCertificate command.
Tried logging out, adding the administrator account through the Default Domain Policy to the User Rights Assignment \ Manage Auditing and Security Log there

added domain\administrator as well as just administrator

No change, still can't run Get-ExchangeCertificate
0
 

Assisted Solution

by:PatrickDoman
PatrickDoman earned 0 total points
Comment Utility
This issue is resolved.

By going into the Default Domain Policy on the DC through Group Policy Management, I was able to add the Exchange Servers group to the Local Policies\User Rights Assignment\Manage Auditing and Secrity Log.

That as well as getting the domain admin account in there allowed me to finally run the Get-ExchangeCertificate command. I then found that the SMTP service was assigned to a expired certificate and was able to run the command Enable-ExchangeCertificate -Thumbprint <thumbprintid> -Services SMTP and it assigned the SMTP service to the correct certificate. All I have left to do is to remove the SMTP service from the Internally generated certificate it has been operating under.

I ran the Enable-ExchangeCertificate -thumbprint <thumbprintidtoremove> -services "none" command.

The server certificate or what appears to be the default system certificate shows it still has the smtp service assigned. Perhaps this is by desing. Now I just need to identify how to renew that since it has expired. Not sure if that certificate being expired is causing any other issues.
0
 
LVL 23

Assisted Solution

by:Stelian Stan
Stelian Stan earned 500 total points
Comment Utility
OK, that means you have to renew the certificate. To do that have a look on this  document: http://www.sslshopper.com/article-how-to-use-ssl-certificates-with-exchange-2007.html
0
 

Author Closing Comment

by:PatrickDoman
Comment Utility
My own troubleshooting allowed for resolution to the issue by putting the Exchange Servers group in the Default Domain Policy so that the Get-ExchangeCertificate command would work. While clonyxlro was able to help me resolve the issue with the knowledgebase article on the updated framework 3.0, my work resolved the issue more evidently as the framework alone was not enough to resolve the issue.
0
 
LVL 23

Expert Comment

by:Stelian Stan
Comment Utility
Glad that is working. Thank you.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now