• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2460
  • Last Modified:

On screen Keyboard

We've enabled an onscreen keyboard in Windows XP and altered a value in the Registry Editor for it to boot up at the logon screen.We've taken "HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS NT\CurrentVersion\WinLogon\" the Sytem Vaue of "OSK.exe" out of the registry but still the machine boots up the On Screen Keyboard.We have also disabled the keyboard in the "Ease of Access" section.Need to disable the osk!
0
The_Nibbler
Asked:
The_Nibbler
  • 5
  • 2
1 Solution
 
Dilip PatidarCommented:
Hello Nibber,

Control Panel, Ease of Access. Then click on the link "Use the computer without a mouse or keyboard". Make sure the checkbox marked "Use On screen keyboard" is UNchecked (ie, clear).

That's your first and most important place to check. After that, it gets a bit more obscure. The On Screen Keyboard program is "osk.exe". Presumably something is causing osk.exe to be run, every time you log in.

In the Start menu, look in the Startup folder. Make sure there are no shortcuts there pointing towards osk.exe. If there are, move the shortcut to another location, or just delete it.

Next, run the command "msconfig". If prompted for admin credentials, enter them. Then, look under the Startup tab. Look for any entries which appear to run osk.exe. If you see one, uncheck teh entry, and then press Apply.

Next, run Regedit. If prompted for credentials, enter your own, current username and password. Then navigate to the registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

If you see a value under there which runs osk.exe, delete that value.

Regard's,

Dilip Patel
0
 
The_NibblerAuthor Commented:
I've already done all of the checks above and still OSK.exe comes up as soon as the pc boots up into XP.One thing that was weird, i deleted or cut the OSK.exe out of the sys32 folder but then it just replicates another OSK.exe in the sys32 folder.Is this normal or could this be a virus of some sorts?
0
 
The_NibblerAuthor Commented:
Any other suggestions?

The osk.exe still boots up after restarting the pc.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
The_NibblerAuthor Commented:
Couldn't get rid of OSK.exe when logging in.I wrote a script that killed the OSK.exe task after the pc has booted up.its been stable for the last 4 days
0
 
The_NibblerAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for The_Nibbler's comment #a38876004

for the following reason:

Could not resolve issue so an alternative method was used to stop service from popping up after pc has booted up.
0
 
Dilip PatidarCommented:
Hello,

You will try Start - All Programs - Accessories - Accessibility - Utility Manager

Select  screen Key Board is not running  - Stop.

Please try it and share the result.
0
 
The_NibblerAuthor Commented:
I've tried all the above mentioned.The On screen keyboard is already unchecked although OSK.exe is still running under the "Processes" tab.No entry in the Registry startup or Windows logon has the "OSK.exe" value in it.That's why i wrote a little batch script to forcefully stop this osk.exe at startup.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now