Outlook Autodiscover

Having an issue with a client site and Autodiscover. (Quick info about the site, Single Domain, SBS 2008 Standard). Outlook is connecting to Exchange fine and users can send and receive emails without issues. The issue is with OOF and Autodiscover. When testing autodiscover through outlook it finds the URL of mail.domain.com/autodisocver/autodiscover.xml through SCP but then fails with a error code 403.

To test this further i wen to Exchange Management Shell and ran test-outlookwebservices |fl. I have pasted the results from this test below in hope that someone can shed some light on this.

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address user@domain.com
         

Id      : 1007
Type    : Information
Message : Testing server WIN2008SBS.domain.local with the published name
          https://mail.domainname.com/ews/exchnage.asmx & https://mail
          .domainname.com/EWS/Exchnage.asmx.

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover
           URL on this object is https://mail.domainname.com/autodisco
          ver/autodiscover.xml.

Id      : 1013
Type    : Error
Message : When contacting https://mail.domainname.com/autodiscover/aut
          odiscover.xml received the error The remote server returned an error:
           (403) Forbidden.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.

When i go to browse the Autodiscover URL I expect to see the error code 600 Invalid Response but instead I get the same error code 403.

I have compared the Virtual Directory permissions against a different server in a different company and the Authentication matches perfectly, so does the Directory Browsing and the Default Document.

If any one can help with this I would be much appreciated. Also if any one needs for information then I am happy to answer.
Ash GhaiManaging DirectorAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Simon Butler (Sembee)Connect With a Mentor ConsultantCommented:
If that is the only wizard that you have run, then you haven't setup the server correctly.
SBS is designed to be installed, configured and managed with the wizards.

In the SBS console there is Getting started tasks. You should run at least the first three of those under Connect to the Internet.
On the setup you Internet Address you would need to do an Advanced configuration to use something other than remote for the host name.

Then once completed run the Add a trusted certificate wizard and the SSL certificate shoudl be available.

Simon.
0
 
Simon Butler (Sembee)ConsultantCommented:
Was the server setup using the SBS wizards? SBS usually likes to use remote.example.com, so it doesn't look like it was, unless you customised the tool.
If you configured things manaully then it could be that you have broken the functionality. SBS 2008 does things a little different to a regular installation which is why it is important that you use the wizards to configure the server.

Browsing to autodiscover will usually give an error, so I wouldn't do much with that.

If the server was setup with the wizards, then run the Fix my Network wizard to begin with and see what that flags up to you.

Simon.
0
 
Ash GhaiManaging DirectorAuthor Commented:
Yes the Server would have been set up using the Wizards, although not by my self. I can confirm though that remote.domain.com was set up originally for OWA etc. However due to the SSL certificate that was bought I had to change the IIS vdirs to match this. All these changes were done through EMS with Microsoft guides to help. After changing these vdirs OWA still works both internally and externally so I would like to think it is not totally broken.

I will run the Wizard to see what is flagged up. If this is the case then is it possible for the Wizard to be re ran and assign the URL mail.domain.com rather than remote.domain.com?

Thanks for help so far.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Simon Butler (Sembee)ConsultantCommented:
If you wanted to use another host name then you should have run the wizard in SBS to change things, rather than doing so outside of SBS. Then after running the wizard to configure the new host name, use the SSL wizard to enable your SSL certificate. That would ensure that everythign was in place as SBS wants it to be. Trying to do things outside of the wizards usually ends up making a mess.

Simon.
0
 
Ash GhaiManaging DirectorAuthor Commented:
Thank you for your reply.

I did not realise this was the case as my SBS knowledge is young. The only Wizard i have seen is in the SBS Console which is for connecting to the internet. If the fix is as easy as running a wizard and providing the new host name and SSL etc then this will be great. Please be more specific on what wizard to run though or provide me with links to help with this.

Thanks again. Will be very happy if this gets resolved.
0
 
Ash GhaiManaging DirectorAuthor Commented:
Simon,

Thank you for your response about running the Wizards. I will run these this week and report back the results and hopefully accept your response as the solution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.