Solved

Bad Request - Invalid Hostname

Posted on 2013-01-17
5
1,796 Views
Last Modified: 2013-01-18
Hi,
In my Win 2008 server, I have published the project fine in "Start" of the site called "WIN-BVDIC8GIAHI". But when I go to this
http://WIN-BVDIC8GIAHI:81/Start

I've got, while I am able to ping "WIN-BVDIC8GIAHI"
Bad Request - Invalid Hostname

HTTP Error 400. The request hostname is invalid.

why?
0
Comment
Question by:HuaMinChen
  • 3
  • 2
5 Comments
 
LVL 29

Expert Comment

by:becraig
ID: 38792690
Can you check your site bindings in IIS

run inetmgr and for the site you intend to browse to ensure iis has the port 81 bound to that hostname.

click on the site in inetmgr and edit binding and from the dropdown select your site and enter the port 81 (you should be good to go)

If any issues you can run iisreset /noforce from the command line.
0
 
LVL 10

Author Comment

by:HuaMinChen
ID: 38795420
Thanks a lot. I can see Site bindings that is

Type      Host name            Port
http      win08.huamin.com      81

is already there. What to adjust on that?
0
 
LVL 29

Assisted Solution

by:becraig
becraig earned 500 total points
ID: 38795454
This indicates that port 81 is bound to win08.huamin.com

You need to create a binding to WIN-BVDIC8GIAHI on another port (e.g 8080 etc) or change the hostname on that binding to reflect WIN-BVDIC8GIAHI.


If you are deploying a testing site you want to configure a different port when deploying your test application, since I am guessing the site on  win08.huamin.com  is a live site.
0
 
LVL 10

Author Comment

by:HuaMinChen
ID: 38795483
Thanks a lot. After I have used "WIN-BVDIC8GIAHI" instead as the hostname and have restarted the machine, I then get this
Server Error in '/Start' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error:

Line 12:
Line 13:   <system.web>
Line 14:     <compilation debug="true" targetFramework="4.0" />
Line 15:
Line 16:     <authentication mode="None">


Source File: c:\inetpub\Start\web.config    Line: 14

Does it mean a problem with the Framework version?

Many Thanks & Best Regards,
HuaMin
0
 
LVL 29

Accepted Solution

by:
becraig earned 500 total points
ID: 38795491
check the framework version for the app pool in IIS

your web.config indicates 4.0 ensure you app pool is set to the same, it might be set to 2.0 instead of 4.0


click on the app pool and you will see the version on the right column
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Viewers will learn about the regular for loop in Java and how to use it. Definition: Break the for loop down into 3 parts: Syntax when using for loops: Example using a for loop:
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question