Lync 2013 calling trunk

I'm having 2 problems with trying to make outgoing calls in our new Lync 2013 server.

First problem:

When I make calls from our new Lync 2013 server to our pstn gateway it sends:
FROM: "John Doe" <sip:john@exampledomain.com>
when it should be something like:
FROM: "John Doe" <sip:+123456789@exampledomain.com>
I even tried Lync Caller ID Supression but it still sends the name instead of the number. The user HAS a tel URI specified and I have tested the call in the admin site and all is a pass.

Second problem:

The gateway/trunk I'm connecting to (a contracted provider) get NO traffic at all from us when we try an outgoing call though we have no firewalls/routers and other things that would block the connection. We have the correct listening port set (TCP, as they don't use TLS).

I have atatched a log from a try to make a call. Nothe that IP's and domain names have been altered for privacy.
Tomas_SvedbergAsked:
Who is Participating?
 
Tomas_SvedbergAuthor Commented:
Project closed. To much problems.
0
 
R_EdwardsCommented:
Tomas there is no attachment
0
 
Tomas_SvedbergAuthor Commented:
Very wierd I used attatch file. ooh well I'll try posting it as a reply. (numbers have been edited for privacy):

TL_INFO(TF_PROTOCOL) [2]124C.1BA4::01/17/2013-11:55:58.638.00000010 (S4,SipMessage.DataLoggingHelper:1823.idx(774))[2336932069]
>>>>>>>>>>>>Outgoing SipMessage c=[<SipTlsConnection_149693F>], 192.168.10.17:5070->192.168.10.17:50182
SIP/2.0 503 Service Unavailable
FROM: "John Doe"<sip:john@my.domain>;tag=94840cd5b5;epid=4fdb620804
TO: <sip:+46123456789@my.domain;user=phone>;epid=A9778207DD;tag=736f918446
CSEQ: 1 INVITE
CALL-ID: 90deb79931e74223bdf9f0208defeff7
VIA: SIP/2.0/TLS 192.168.10.17:50182;branch=z9hG4bK0D6933DC.C79F5C2C4C208D1E;branched=FALSE,SIP/2.0/TLS 10.20.10.166:5780;received=321.321.321.321;ms-received-port=5780;ms-received-cid=2100
CONTENT-LENGTH: 0
SERVER: RTCC/5.0.0.0 MediationServer
ms-endpoint-location-data: NetworkScope;ms-media-location-type=intranet
ms-trunking-peer-state: down
ms-trunking-peer: 123.123.123.123;trunk=123.123.123.123
ms-enable-dns-failover: yes
ms-diagnostics: 10001;source="lync.my.domain";reason="Gateway did not respond in a timely manner (timeout)";component="MediationServer"
ms-diagnostics-public: 10001;reason="Gateway did not respond in a timely manner (timeout)";component="MediationServer"

Open in new window

0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
Mohammed HamadaSenior IT ConsultantCommented:
Thomas, this could be related to mediation service/server problem or dial plan. maybe you should check if you have a +.. try to remove it from the dial plan assigned with the calling user.

make sure you also change the listening port to 5060. you could probably sit the wrong port in the topology.
0
 
Gajendra RathodSr. System AdministratorCommented:
Please check port number of mediation.

Go Task Manager | Services | note PID of mediation service

Go CMD| netstat -ano | check for PID and listening port.
0
 
Tomas_SvedbergAuthor Commented:
Thank you for your help!
0
 
Tomas_SvedbergAuthor Commented:
Project closed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.