Solved

ASP.NET Membership service creating  Applications

Posted on 2013-01-18
11
544 Views
Last Modified: 2013-01-18
I'm using the ASP.NET membership service in my application, but for some reason it creates 2 ApplicationIDs in the Applications table.

I've set the ApplicationName attribute in the web.config, but it still occurs. I have have the correct application name I've defined, and also a default application called '/' that gets created.

Any idea why this happens, as users are created for both, bu the membership table only gets populated with users for the '/' applicationID.
0
Comment
Question by:wint100
  • 6
  • 5
11 Comments
 
LVL 41

Accepted Solution

by:
guru_sami earned 500 total points
ID: 38794043
Most likely it is from Role Provider or Profile Provider. Check this
0
 
LVL 1

Author Comment

by:wint100
ID: 38794058
Hmm, great info, but I dont have these elements in my web.config at all. I only have the MembershipProvider defined. Do you think this could be the problem?
0
 
LVL 41

Expert Comment

by:guru_sami
ID: 38794069
/ may be created from your old setting before you had your new ApplicationName set.

If you create a new user do you see two users being created in aspnet_Users table or just one?

If just one you don't need to worry.

Or you can share your membership provider settings from web.config here.

Or for some reason it could be from conflicting settings from your machine.config.
0
 
LVL 1

Author Comment

by:wint100
ID: 38794077
I cleared out the table today and I still get 2 x Applications created and new users are created twice. Annoying thing is that the Membership tabe gets populated with Users from the '/' ApplicationID, but UsersInRole has users from '/MyApplicationName' ApplicationID. The service works well, but if I do alookup on the Users email based on Role, it returns nothing because the UserID for the Role doesn't exist in the Membership table.

<membership>
      <providers>
        <clear />
        <add name="AspNetSqlMembershipProvider" 
             type="System.Web.Security.SqlMembershipProvider, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" 
             connectionStringName="LocalSqlServer" 
      enablePasswordRetrieval="true" 
      enablePasswordReset="true" 
      requiresQuestionAndAnswer="false" 
      applicationName="/MyApplicationName" 
      requiresUniqueEmail="false" 
      passwordFormat="Encrypted" 
      maxInvalidPasswordAttempts="20" 
      minRequiredPasswordLength="4" 
      minRequiredNonalphanumericCharacters="0" 
      passwordAttemptWindow="10" 
      passwordStrengthRegularExpression="" />
      </providers>
    </membership>

Open in new window

0
 
LVL 41

Expert Comment

by:guru_sami
ID: 38794090
where is your RolesProvider in web.config or machine.config? Check your machine.config as that's my doubt.

Also try changing the name of the provider and also add defaultProvider attribute to your membership provider

<membership defaultProvider="MyCustomMembershipProvider">
<providers>
        <clear />
        <add name="MyCustomMembershipProvider" ......
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 
LVL 1

Author Comment

by:wint100
ID: 38794107
It is in the web.config as this gets deployed with my application, I don't touch the machine.config and this happens on my dev machine and production.
0
 
LVL 1

Author Comment

by:wint100
ID: 38794129
Also, there i no mention of my RoldProvider in the web.config, the only mention of roles and permissions is as follows:

<roleManager enabled="true" />
    <authentication mode="Forms">
      <forms name=".MyApplicationName_ASPXAUTH" />
    </authentication>
    <profile>
      <properties>
        <add name="FriendlyName" />
        <add name="PictureURL" />
        <add name="Permissions" />
        <add name="AllowedSites" />
      </properties>
    </profile>

Open in new window

0
 
LVL 41

Expert Comment

by:guru_sami
ID: 38794130
If you don't have your RolesProvider defined in your web.config, it is taking up from machine.config. You can define it explicitly in your web.config like in the link I provided earlier.
0
 
LVL 1

Author Comment

by:wint100
ID: 38794141
That's great, I'll test it ASAP. Thanks
0
 
LVL 41

Expert Comment

by:guru_sami
ID: 38794158
Oh I missed your other comment with roles provider...so it looks you need to define both Roles and Profile Providers explicitly and set the applicationName as your membershipprovider.
0
 
LVL 1

Author Comment

by:wint100
ID: 38794292
Seems to have worked perfectly, thanks, just need to update my installer and release a new build now.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Slowly Changing Dimension Transformation component in data task flow is very useful for us to manage and control how data changes in SSIS.
The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties
Via a live example, show how to setup several different housekeeping processes for a SQL Server.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now