Removing old ESXi 5 install

I've setting up a ESXi 5.1 server and initally installed ESXi on the RAID 1+0 array I'm using for VM storage (and the only datastore in the system). I then decided to install it to an internal USB memory stick. This works fine but how do I get rid of the partitions containing the old install so I can use the full array for storage?

ls /vmfs/volumes
lists 5x guids and the datastore.

/etc/init.d # ls /vmfs/devices/disks
Who is Participating?
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
yes, you can use  partedUtil

see here
Neil RussellConnect With a Mentor Technical Development LeadCommented:
delete the array and reconfigure the partitions.
mark_667Author Commented:
If you mean reboot the server and reconfigure the array in the RAID management config and then recreate the datastore, I'm trying to avoid that as it takes several hours to rebuild the array. I was hoping I'd be able to delete the partitions using partedUtil and extend the datastore somehow?
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
the easiest way would be to DELETE the array on the current disks.

I would also remove the disks, and move the order of disks around, so the array structure changes.
mark_667Author Commented:
@hanccocka do you mean I'll have to recreate the array and wait hours for it to reinitalise? Is there any way I can just do this in VMWare?
Neil RussellTechnical Development LeadCommented:
Hours to reinitialise? What array controller do you have and how many disks?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if you are familiar with fdisk or gparted utils

you can remove the partitions manually. But sometimes partition utilities struggle to remove the partitions.
mark_667Author Commented:
GParted doesn't look like it can handle VMFS

Could I use FDisk to delete the partitions used by the old install and extend the datastore into the freed space using partedUtil (preferable without losing any of the existing data on there)?
mark_667Author Commented:
i tried using partedUtil to delete the partitions but ran into a problem with a fwe of them:

partedUtil delete "/vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04" 2
Error: Read-only file system during write on /dev/disks/naa.600508e00000000081546d64bdb3ad04
Unable to delete partition 2 from device /vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04

partedUtil delete "/vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04" 4
Unable to retrieve partition 4 from device /vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04

partedUtil delete "/vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04" 7
Error: Read-only file system during write on /dev/disks/naa.600508e00000000081546d64bdb3ad04
Unable to delete partition 7 from device /vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04

# partedUtil getptbl "/vmfs/devices/disks/naa.600508e00000000081546d64bdb3ad04
121469 255 63 1951399936
7 1032224 1257471 9D27538040AD11DBBF97000C2911D1B8 vmkDiagnostic 0
2 1843200 10229759 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0
3 10229760 1951399902 AA31E02A400F11DB9590000C2911D1B8 vmfs 0
~ #
I tried a gparted live CD but it couldn't see the array (I presume because it didn't have the necessary drivers for the card).
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
it's much quicker to destroy the current RAID (because some partitions are cached and cannot be deleted).
If you use a block-level disk editor, you can write zeros to sectors 0x0000-0xFFFF, wiping out the partition table.

You will also want to wipe the last few blocks of the array's volume, as a second copy of the partition table could be lurking there.

If you can boot WinPE (BartPE?) , the free HxD hex editor (for Windows) works well. You might also find a copy of the DOS "Norton Disk Editor" which can do the same thing, but might not work with your array's bios support.
mark_667Author Commented:
@modus_operandi, what do you mean? I did split the points.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.