Enable sFlow on HP Procurve 4208lv switch

We are implementing Solarwinds NTA and I'm trying to get sFlow working on my HP Procurve 4208vl switch.

I was able to enable sFlow by entering the following commands:

setmib sFlowRcvrAddress.1 -o 0A00020C  (
setmib sFlowRcvrOwner.1 -D sFlowowner sFlowRcvrTimeout.1 -i 100000000
setmib sFlowRcvrPort.1 -i 2055

After entering "walkmib ifName" to get the PVID mappings - I entered these command to configure port C2:

setmib sFlowFsReceiver. -i 1
setmib sFlowFsPacketSamplingRate. -i 512
setmib sFlowFsMaximumHeaderSize. -i 128
setmib sFlowCpReceiver. -i 1
setmib sFlowCpInterval. -i 30

After any of these commands, the following message is returned:

sFlowFsReceiver. Unable to create.

Can someone help me to get this working?

Useful Information:
Software revision  : L.10.23  
 ROM Version        : L.10.03

sFlowVersion.0 = 1.3;HP;L.10.23
sFlowAgentAddressType.0 = 1
sFlowAgentAddress.0 = 0a 00  02 11
sFlowRcvrOwner.1 = sFlowowner
sFlowRcvrTimeout.1 = 99,946,298
sFlowRcvrMaximumDatagramSize.1 = 1400
sFlowRcvrAddressType.1 = 1
sFlowRcvrAddress.1 = 0a 00  02 0c
sFlowRcvrPort.1 = 2055
sFlowRcvrDatagramVersion.1 = 5

Websites I used for info:
Who is Participating?
AngealConnect With a Mentor Author Commented:
I looked at our config and ports C1-C4 were part of a trunk group. After running the walkmib ifName command, and the very bottom I found:

ifName.209 = Trk1

Trk1 contains C1 - C4
I ran the commands above, and they worked.

Thanks very much Rharland2009 for your help!
Try your commands spelled out MIBwise in the setmib.
Like this.

setmib -i 1
AngealAuthor Commented:
Hi Rharland2009,

Unfortunately, I received the same response: Unable to create.
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

rharland2009Connect With a Mentor Commented:
Okay. Just curious - if you do a getmib of that same string, do you get a result?
AngealAuthor Commented:
getmib -i 1
Cannot translate variable -i.
rharland2009Connect With a Mentor Commented:
Sorry, leave the variable and value off.
AngealAuthor Commented:
Odd, port C2 (ifname.54) results with "no such name" but a higher number port D22 (ifname.100), I received a return value of 0:

# getmib sFlowFsReceiver.
sFlowFsReceiver. No such name.

# getmib sFlowFsReceiver.
sFlowFsReceiver. = 0
Try to configure your steps on the higher interface and post results.
No problem....glad it's working for you!
AngealAuthor Commented:
Extremely helpful! Thank you Rharland2009 for pointing me in the right direction.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.