SCCM 2012 3rd Party deployment

Trying to install a 3rd Party application. They provided the MSI but with a batch file that includes all the flags and location modification. I had it working once then was not able to again. Here is the error message I get

The software change returned error code 0x80070003(-2147024893).

I have SCCM 2012 with SQL 2012 on a Windows 2008 R2.

1. I create a custom 32 bit application in SCCM.
2. Deployment type is Script and I am pointing to the batch file (witch is located on a windows share).
3. Deployments it for system only eve if the user if not logged on.

In the Deployment Type I have the programs that point to the shared drive as shown:
"I:\shared\Mimsy 1.5\mimzy_batch.bat"

The batch file looks like this:
msiexec /i "[INSTALLDIR]setup.msi" /passive APPDIR="[APPDIR]" SERVERDIR="[SERVERDIR]" SERVERNAME="[SERVERNAME]" DBPORT="[DBPORT]" DBNAME="[DBNAME]" CONNECT_STRING="jdbc:oracle:thin:@[SERVERNAME]:[DBPORT]:[DBNAME]" XG_CLASSPATH="[SERVERDIR]xg.jar;[SERVERDIR]quick.jar;[SERVERDIR]ssce\runtime\lib\ssce.jar" CRJ_CLASSPATH="[SERVERDIR]crviewer.jar;[SERVERDIR]crsupport2\CrystalReportsRuntime.jar;[SERVERDIR]crsupport2\DatabaseConnectors.jar;[SERVERDIR]crsupport2\keycodeDecoder.jar" CRJCOMMON_CLASSPATH="[SERVERDIR]crsupport2\CrystalCommon2.jar;[SERVERDIR]crsupport2\commons-collections-3.1.jar;[SERVERDIR]crsupport2\commons-configuration-1.2.jar;[SERVERDIR]crsupport2\commons-lang-2.1.jar;[SERVERDIR]crsupport2\commons-logging.jar" CRJEXTRAS_CLASSPATH="[SERVERDIR]crsupport2\com.azalea.ufl.barcode.1.0.jar;[SERVERDIR]crsupport2\cvom.jar;[SERVERDIR]crsupport2\icu4j.jar;[SERVERDIR]crsupport2\JDBInterface.jar;[SERVERDIR]crsupport2\jrcerom.jar;[SERVERDIR]crsupport2\pfjgraphics.jar;[SERVERDIR]crsupport2\QueryBuilder.jar;[SERVERDIR]crsupport2\xpp3.jar" CRJLOG_CLASSPATH="[SERVERDIR]crsupport2\log4j.jar;[SERVERDIR]crsupport2\logging.jar" DB_CLASSPATH="[SERVERDIR]ojdbc6.jar;[SERVERDIR]orai18n.jar" IB_CLASSPATH="[SERVERDIR]IB.jar;[SERVERDIR]exif.jar" IMAGING_CLASSPATH="[SERVERDIR]jai_imageio.jar;[SERVERDIR]jai_core.jar;[SERVERDIR]jai_codec.jar;[SERVERDIR]jmagick.jar" MAIL_CLASSPATH="[SERVERDIR]activation.jar;[SERVERDIR]mail.jar;[SERVERDIR]moyocore.jar;[SERVERDIR]joc-v2.0.4.jar;[SERVERDIR]domingo-1.5.1.jar" XGAPI_CLASSPATH="[SERVERDIR]xg.jar"

Any idea why I cannot just make the batch file run the msi in an Application deployment true SCCM.

What are your recommendations.

Thank you,
Francis
PotsAsked:
Who is Participating?
 
merowingerCommented:
The error message the user get is:
The system has detected a possible security risk. Make sure that you are using the server that you have authenticated.have you tried to run the Package from Disitrubtion Point or Local. I would play with those options
0
 
PotsAuthor Commented:
OK if I install the application as Users only. It was successful with a domain admin account. A normal user is now receiving 0x800704F1

I am continuing me research. If you have any tips I'd appreciate them..

Thank you.
0
 
PotsAuthor Commented:
Hi, I have tried to run it both ways.

Now running it from the Dist Point give me an error:

The software change returned error code 0x643(1603).

So it is different.

But both ways I can see the Installer start on the client and almost as it finishes it Fails.

And again with the domain admin account this installs correctly.

If I try to install On System instead of As User it fails also.

Any ideas?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.