Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 428
  • Last Modified:

Visual Studio Web Copy question mark keeps indicating unknown which file is newer

I have TFS and Visual Studio 2010. There are certain files that when I use the Web Copy feature in Visual Studio, they have a question mark next to them, indicating that it doesn't know if the file is the same as on the server or not.

I can copy the files over, the question mark goes away, and then I close and reopen visual studio and go to web copy again and there they are again.

How do I get those question marks to go away and have it "reset" itself. Are there hidden files being tracked or somewhere I can reset the saved values so it will start tracking them accurately?

TFS question marks need to go away

In this msdn post it says:
http://msdn.microsoft.com/en-us/library/xay0wxbf(v=vs.80).aspx
The Default.aspx files have question marks (?) next to them. This indicates that the file has the same name in both sites, but different timestamp data and no information about the last time the files were copied.

I need to get my timestamps in sync and don't know how. They show ?'s everytime I copy.

I have tried:
making slight changes, saving, and recopying.
deleting the file entirely and adding back.
synching between sites.
copying from the remote to the local instead of local to remote.
Once I close out and restart the Web Copy, the question marks show on the same files all over again. Always the same files.

thanks.
0
Starr Duskk
Asked:
Starr Duskk
  • 2
1 Solution
 
Obadiah ChristopherCommented:
Did you try doing a clean solution? I see that the file on the remote site is showing a newer timestamp.
0
 
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
what do you mean? clean solution.

And yeah, I have another forum post about that. The files are the same.

It used to be that you could set visual studio to retain the original timestamp as the files on your local. But it has a timestamp of the date/time you copied it, not the timestamp of when the local file was saved. So they're never in sync.

I used to always use the option on the web copy page to keep local file timestamp. No one seems to be able to tell me where that went. I wonder if it's a VS2010 thing.
0
 
Starr DuskkASP.NET VB.NET DeveloperAuthor Commented:
Closing this out. No one ever got back with me for clarification. But moving on.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now