Go Premium for a chance to win a PS4. Enter to Win


Unable to install SP2 Rollout 4

Posted on 2013-01-18
Medium Priority
Last Modified: 2013-01-29
I am trying to install Rollup 4-v2 on Exchange 2010.  I tried this on 2 different servers and I come up with the same error.  I did stop IIS prior to install.

"Setup wizard for Update Rolloot 4-v2 for Exchange Server 2010 Service Pack 2 (KB2756485) ended prematurely."

I do get error 1603 in the eventlog and I have followed this:
http://go.microsoft.com/fwlink/?LinkID=191548 but it has not helped.

Any suggestions?
Question by:FundFire
  • 7
  • 2
  • 2
LVL 44

Expert Comment

ID: 38794453
Did SP2 is already installed?

Author Comment

ID: 38794563
Yes.  The version that I have is 14.2 Build 247.5.
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38794689
Why dont you try to upgrade to RU5v2 ?
Is the Installer service running on the server ?
Did you try to download a fresh file and install ?

- Rancy
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.


Author Comment

ID: 38805618
I tried RU5v2, the same thing.
Installer service was not running I started it but I got the same error.
Download fresh copy, the same thing.
LVL 44

Expert Comment

ID: 38805636
can you run sfc /scannow from cmd

Author Comment

ID: 38805685
I ran it and got back:
Windows Resource Protection did not find any integrity violations.

Author Comment

ID: 38805893
I captured the log in case you guys can see something in there.

Author Comment

ID: 38807201
Hi guys,

One question, how do you upgrade exchange sp1 to sp2?

Accepted Solution

FundFire earned 0 total points
ID: 38814340
I was finally able to install Roll up 4.  These are the things that I did:

Followed this link:

especially the section that says this:

1- My problem was that I installed PowerShell v3 before Update Rollup 4-v2, so "control cannot leave a finally block" was an issue. Rather than substituting an entirely blank script or commenting out the return statement in C:\Program Files\Microsoft\Exchange\V14\Scripts\ManageScheduledTask.ps1, I changed "return $success" to the logically equivalent "Write-Output $success" in line 462. I also removed the now invalid digital signature. My ExecutionPolicy was already RemoteSigned. With these changes the rollup installed normally. The rollup didn't replace the ManageScheduledTask.ps1 script. I ran the rollup msp from the GUI rather than an elevated command prompt. I was logged on as a builtin Administrator. That didn't seem to be a problem. I did open its properties page and unblock it, however.

2- I downgraded my powershell to V 2.
uninstall WMF 3.0 (which includes PowerShell 3.0, which is not suitable for Exchange 2010) from Control Panel > Programs and Features. No need to uninstall .NET 4 - it runs side-by-side with .NET 3.5 and is not an upgrade.

3- I DID NOT do this, it would not install, I left it as Remotesinged.
PowerShell : Set-ExecutionPolicy -scope LocalMachine - ExecutionPolicy Undefined

After this I was able to install.  

I have to say this was so frustrating because this was a fresh install and I had to go through this to install a roll up.  Microsoft needs to do better testing.

Author Closing Comment

ID: 38830296
I was not able to get a bottom of this through expert exchange and followed other link.  Although I really appreciate all the assistance I received.

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
This month, Experts Exchange sat down with resident SQL expert, Jim Horn, for an in-depth look into the makings of a successful career in SQL.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question