Error message in Exchange 2003 Standard SP2: This database will be dismounted immediately

Our Exchange server unexpectedly stopped working today and we had to reboot it in order to get emails working, below is the error message:

Exchange store 'First Storage Group\Mailbox Store (LSLPSRV05)': The logical size of this database (the logical size equals the physical size of the .edb file and the .stm file minus the logical free space in each) is 151 GB. This database size has exceeded the size limit of 75 GB.

This database will be dismounted immediately.

 I'm trying to find out what can be done about this so we don't have to reboot our server when this error does occur.
twinturboV6Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tvedtemCommented:
Since 75GB is the upper limit for ES2003 you need to make some space - possibly by:
- ask users to clean up
- remove old accounts
- defragment

If that's not particularly effective then it's time to upgrade to 2010.

However before touching it have a look @:
http://support.microsoft.com/kb/828070
0
twinturboV6Author Commented:
We could get user's to clean up their mailbox and delete items that aren't needed, and we are planning to upgrade to Exchange 2010 in the near future. We can't remove old accounts because of ligatory purposes, since we more than doubled the database size limit, a disk defrag might not be ideal. What if we moved some of the mailboxes over to another database  ? I am thinking that might be a good short term solution fix until we get Exchange 2010 in place.
0
tvedtemCommented:
Just to be clear, you defrag the exchange DB itself (as opposed to the disk)
http://support.microsoft.com/kb/328804
(see Offline defragmentation)

But if you suspect that this could be disruptive you are probably correct !  It's an out-of-hours kinda thing.

Your idea of moving users will help to some extent I think (perhaps move every expired account to the new one or something like that).

The problem you might have is that you'll only see the full benefit of moving some users / deleting big e-mails if you subsequently defragment (since this is the only way to get the actual file sizes down).  I guess it depends how long you need to soldier on for before an upgrade.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Simon Butler (Sembee)ConsultantCommented:
If your database is being reported as 151gb, then this has to have been happening every day for some time, or you have had a large amount of growth in a very short time.
You don't have to restart the server, you can just restart the information store. However it is going to happen every day. Schedule a restart of the information store service for 5.10am.

An Offline Defrag is a waste of time - the white space is already taken in to account by the database limit enforcement system - it isn't the physical size alone.

I would suggest bringing forward a migration to Exchange 2010.

Simon.
0
twinturboV6Author Commented:
Thanks much for the advice guys, Simon the database was dismounted exactly at 5:00:21 AM on our server (event ID 9690), shortly after it spit out another event ID (error 9539) at 5:00:59 and said that "First Storage Group\Mailbox [LSLPSRV05]" was stopped".

Should I schedule a restart of the information store service before it checks the database size limit ?  (5:00 am)
0
twinturboV6Author Commented:
Attached is the error messages from event viewer
Exchange-error---jan.18.2013.docx
0
twinturboV6Author Commented:
One last thing, I go to services.msc / Microsoft Exchange Information Store / right click, properties / under General tab, the startup type is set to Automatic / under Recovery tab there are some options  - First failure is set to "Take no Action", Second failure is set to "Take no Action", Subsequent failure is set to "Take no Action".

When I click the drop down on each I see the option "Restart the service". Would that be sufficient ?

... My apologies if I sound green.. I'm kind of new at all this server related stuff.. I done years of desktop support and just now trying my hand at this higher level stuff.
0
Simon Butler (Sembee)ConsultantCommented:
The check is at 5am by default, so the behaviour you have seen is correct.
Choosing to restart the service in Services isn't enough. You need to schedule a service restart at 5.05am or something to get the database to come back online.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
twinturboV6Author Commented:
Ok I think I got it, I used Task Scheduler under control panel and pointed it to the file that handles the Microsoft Exchange Information Store, under event viewer it says "mdbmsg.dll", I was under the assumption that task scheduler only does applications but thaught to give this a try. I have scheduled it to run at 5:05AM every day. I hope this works. I've attached screens.

If this doesn't work, I'm guessing I have to start learning how to write scripts or batch files.
0
twinturboV6Author Commented:
Ok, after creating that scheduled task and thinking about it for a sec, I realized that you can't have a .dll file to restart a service.. I went back to services.msc and took a look at Microsoft Exchange Information store and checked the properties and found it to be what I know it should be - an .exe file

"D:\Program Files\Exchsrvr\bin\store.exe"

So I deleted the previous task and created a new one using Task Scheduler.. I think I got it now.
0
Simon Butler (Sembee)ConsultantCommented:
The way that I would do it is to create a batch file.

net stop "Microsoft Exchange Information Store Service"
net start "Microsoft Exchange Information Store Service"

(check the exact names of the services, as I am not with an Exchange 2003 server at the moment).

Then schedule the batch file to run.

You cannot just use the information store application, as the service will already be running.

Simon.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.