cannot connect via IMAP on exchange 2010 server

Hi, I have a 2011 sbs. I cannot get IMAP to work on it internally. I have IMAP service started, and the users I'm testing have IMAP enabled. I can telnet port 143 and i get the server response.

On outlook or say a phone, I always get username and password failed.
I've tried
username
domain\username
domain.local\username

there's no firewall on the server, just AVG AV

Any ideas.
total123Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
cpmcomputersConnect With a Mentor Commented:
Ok suggest you look at this as a means of making imap more secure

http://exclusivelyexchange.com/how-to-connect-pop-and-imap-clients-to-exchange/
0
 
cpmcomputersCommented:
Check iis websites are all working ?
0
 
cpmcomputersCommented:
Also run
Www.testexchangeconnectivity.com 
And check what that offers
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
total123Author Commented:
IIS looks ok from my limited knowledge of it. OWA and activesync work fine and have done for years.

Is certain section of IIS I should be looking at.
0
 
total123Author Commented:
test exchange for activesync reports all fine
0
 
cpmcomputersCommented:
Just remembered something have a look here:

Exchange Management Console -> Server Configuration -> Client Access -> "POP3 and IMAP4" tab -> IMAP -> Properties

Under the Authentication Tab, by default it is set to Secure Logon (requires TLS).
You mau need plain text

Should be the same for pop3 ?

Also check under the Binding tab and confirm that the correct ports are bound to an available (or all) IP address of the server.

You do not have a gap in your domain name per chance (that is known to create a problem
0
 
d0ughb0yPresident / CEOCommented:
Of course, if that last suggestion turns out to be the fix, realize that your users will now be transmitting their login credentials in the clear. That means, that anyone, say, wireless snooping will be able to just grab their creds directly from the air.
0
 
cpmcomputersCommented:
The questioner does specifically say IMAP internally
0
 
total123Author Commented:
cpmcomputers, that seems to have worked.
as d0ughb0y said, is our security not compromised. We may want to use IMAP for phones in the future that don't support activesync.
0
 
cpmcomputersCommented:
Yes he is correct
There is a potentiial security risk
But now you know it is an authentication issue
Now turn the authentication to the default

You now need to configure your server for ssl connectivity on port 995 only
But this depends on your ssl certificate
Is it the inbuilt cert or a third party cert

The other question I should ask is why you need to enable imap at all ?
0
 
total123Author Commented:
We have a godaddy SSL

In our warehouse the mobile devices only support IMAP or pop over WiFi or 3g. Not active sync.
0
 
total123Author Commented:
all works weel, discovered issue with nokia devices after fixing imap issue

thankyou
0
 
cpmcomputersCommented:
Good Job :-)

Pleased to have assisted
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.