• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 309
  • Last Modified:

RDP problem

Hi - I do work for a restaurant where we want to have RDP access to one of the machines in the office accessible from outside the router. We have a Verizon DSL router that has to connections to it. The first is connected to a sonicwall firewall that ONLY is connected to the POS system, and the other is connected to a Linksys wireless router which has DHCP enabled and is pushing addresses to all of the other machines on the network, including the one we are trying to access. I've configured RDP on the machine (windows firewall/system-remote access) as well as opening the ports on the Verizon DSL modem/router, as well as opening the port on the Linksys router. BUT, for some reason, cant access the machine outside the network, but CAN from within the network. This is a simple network, no AD, no server. I've attached a diagram on how we have it setup - any help would be appreciate!
DIAGRAM.jpg
0
hodgem
Asked:
hodgem
2 Solutions
 
joelsplaceCommented:
Have you checked to make sure that RDP works inside the network?
The Verizon router should have it's RDP port open to the Linksys external IP.
I have had issues with Linksys routers and private IPs on the external interface.
Is there a reason you can't get rid of the Linksys and just run the SonicWall?
Have you tried connecting a PC on the WAN side of the Linksys to see it you can get through the Linksys with the current settings?  If yes, try connecting the RDP PC in place of the Linksys and see if you can get to it from outside.  That will isolate the problem to the Verizon router or the Linksys.
You could try flashing DD-WRT on the Linksys.
0
 
Tony GiangrecoCommented:
For RDP to work properly, you have to setup port forwarding for port 3389 to that Pc. If you don't know how to set that up properly or have difficulty with the Linksys and Verison routers, you can simply go to www.logmein.com and setup a free account. After that is done, you can install Logmein on the Pc you want to access. From that point on, you can log into logmein from any Pc outside of the resturant and connect to the desktop of that Pc in the resturant just like RDP.

The free version of Logmein does not provide remote printing, but you can gerate a report file on that Pc and send it to yourself by email.

We use Logmein central to access all our client's Pc's remotely and it works great.

Hope this helps.
0
 
joelsplaceCommented:
Sorry about that first ?  I just noticed you already answered it.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
hodgemAuthor Commented:
Yes, RDP is working internally. One thing I forgot to mention, I created a custom RDP port for this machine (4010), and made the appropriate change in the registry. The reason I can't use Sonicwall is because it was provided by POS company ONLY for POS system (credit card transactions etc) and we're using the linksys for wireless or I'd get rid if that and just use the Verizon router - I was assuming that since all necessary ports were open, and gateway was correct that it should get through
0
 
joelsplaceCommented:
It's easy to use the Linksys for wireless only and not a router.
Connect to the Linksys and give it a LAN address that works on the Verizon LAN.
Turn off DHCP on the Linksys LAN.
Connect a Linksys LAN port to a Verizon LAN port.
You won't use the Linksys WAN port.
Done.
I have 3 on my home network setup like this.
0
 
cgitekCommented:
This question has been answered numerous times. You have a double-nat condition which can cause you other problems but this is specifically what you need to do.

Assign Linksys Router Static IP Address from 192.168.1.x /24 subnet. Make sure to use one outside the DHCP range or exclude that address.

In DSL Modem port forward TCP 3389 to the newly created static IP address of the Linksys Router.

In Linksys Router port forward TCP 3389 to the Statically Assigned IP address of the PC.

Done.

Note - you may have problems going from inside the LAN network to the Public IP of the DSL modem and routing back into the LAN again. Some devices do not handle this well.

Edit: You may also want to change the listening port on the DSL modem to something other than TCP 3389 for security reasons. Then in the RDP window after the FQDN or IP include a ":<port_number>".
0
 
airwrckCommented:
Call Verizon and ask them if they're permitting port 3389 to your network.  They are notorious for filtering inbound port 80, 25, 443, 1723, and 3389 on residential networks.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now