Solved

Windows Vista 32 reports all USB drives as Unknown device

Posted on 2013-01-21
15
666 Views
Last Modified: 2013-01-23
I am working on a Gateway desktop running Windows Vista 32 that will not recognize any USB drives.  When I plug in any USB hard drive or Flash drive I get:
"Windows needs to install driver software for your unknown Device"
I have tried "Locate and Install driver software (Recommended)"
I have tried pointing it to C:\Windows\system32 and all subfolders as well as the root directory
In all cases it comes back with "Windows couldn't find driver software for your device".
The device shows up in Disk Manager at this point but does not have a drive letter assignment and you cannot assign one.  It also shows up in safely Remove Hardware as just USB Mass storage Device.

I have done all the usually things like uninstalling all USB entries and rebooting.  I have searched all over with Google and tried various fixes as well as Microsoft Fix it with no change. I have also performed a full cleaning and malware scan.

Specs:
Gateway GT5674
AMD 9500
Windows Vista 32 SP2

I have run out of ideas... Any help would be appreciated!
0
Comment
Question by:waytron
  • 7
  • 2
  • 2
  • +4
15 Comments
 
LVL 19

Assisted Solution

by:helpfinder
helpfinder earned 100 total points
ID: 38800951
try to install chipset driver from manufacturer´s web site
0
 
LVL 1

Author Comment

by:waytron
ID: 38801018
Unfortunately, which is often typical of Gateway, there are no drivers listed for this model computer.  Just blank for all versions of Windows.
0
 
LVL 27

Assisted Solution

by:Jason Watkins
Jason Watkins earned 100 total points
ID: 38801047
Here is the driver page for the specific model computer.

http://support.gateway.com/us/en/product/default.aspx?partNumber=1015322R

Though, it does not specifically list the chipset or USB drivers, try the hardware detection utility.
0
 
LVL 1

Author Comment

by:waytron
ID: 38801112
I was just on the Gateway site yesterday and that whole section was empty.  Thanks I will work with that and get back to you later.  I have to leave for a few hours
0
 
LVL 19

Accepted Solution

by:
Miguel Angel Perez Muñoz earned 100 total points
ID: 38801221
0
 
LVL 42

Assisted Solution

by:Jackie Man
Jackie Man earned 100 total points
ID: 38803870
Run cmd in an elevated command prompt and run the command below.

sfc /scannow

You need to Vista setup DVD in case if there are any missing system files.
0
 
LVL 91

Assisted Solution

by:nobus
nobus earned 100 total points
ID: 38804349
you can have an hardware problem
test that by running from a live Knoppix cd - the USB ports should work fine then :
ftp://mirrors.kernel.org/knoppix-dvd/KNOPPIX_V7.0.4bootonly-2012-08-20-EN.iso 

if not - the hardware is bad
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 1

Author Comment

by:waytron
ID: 38805005
Thanks Nobus but I already ran a live version of Ubuntu and flash drives work fine.  Also all other USB devices were working fine such as Mouse, Keyboard and printer.
0
 
LVL 1

Author Comment

by:waytron
ID: 38805049
thanks Jackieman,  Sfc /scannow did not return with any problems?
0
 
LVL 1

Author Comment

by:waytron
ID: 38805055
Thanks Drashiel,  as I mentioned in my original post, I ran the Microsoft fix it and it did not find any problems.
0
 
LVL 42

Expert Comment

by:Jackie Man
ID: 38805085
Can you look up what software has been installed via control panel?

It sounds like a software, such as antivirus or printer software has interrupted with the USB device.
0
 
LVL 1

Author Comment

by:waytron
ID: 38805099
Hi Jakieman,

It originally had Norton 360 but I uninstalled it thinking it might be the cause.  I also ran the Norton removal tool to makes sure.  It has no security software installed at this time.
0
 
LVL 91

Expert Comment

by:nobus
ID: 38805741
if this problem is recent, a system restor e can help
or uninstalling the latest updates
otherwise  you may need a fresh install
0
 
LVL 30

Expert Comment

by:pgm554
ID: 38806105
0
 
LVL 1

Author Comment

by:waytron
ID: 38809413
Well, I finally decided to toss in the towel on this one and just re-install Windows Vista.  I have spent too much time on it already.
Thank you all for your suggestions.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Vmware iSCSi/Fiber Channel Multipathing Configuration 7 77
Solaris SUN OS 4.1.3 machine clone 3 41
DPM 2016 can't see iSCSI disk 5 45
Dell Server drives 9 22
I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now